Bug 22323 - iPad Simulator Crash
Summary: iPad Simulator Crash
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: iOS
Classification: Xamarin
Component: Debugger ()
Version: 5.2
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-08-23 15:49 UTC by adam
Modified: 2016-05-25 00:53 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
iPad_Simulator_Crash_Log (13.07 KB, application/octet-stream)
2014-09-14 14:51 UTC, adam
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description adam 2014-08-23 15:49:03 UTC
• Using Xamarin Studio 5.2.1 (build 1)
• On a Mac running 10.9.4


1) Create a new EMPTY iOS IPAD project
2) Create a root UIViewController that your application launch with, such as the following:
using System;
using MonoTouch.UIKit;

namespace iPadSimulatorTest.iOS
{
	public class HomeViewController : UIViewController
	{
		public HomeViewController ()
		{
		}
		public override void ViewDidLoad ()
		{
			base.ViewDidLoad ();
			Console.WriteLine ("HomeViewController.ViewDidLoad()");
		}
	}
}
3) Update your AppDelegate to use the new HomeViewController by doing the following:
window.RootViewController = new HomeViewController ();
4) Select "Debug" as the build type, and "iPad OS 7.1"
5) Build - Build will be successful
6) Start Debugging
7) It may crash back to iOS home screen after starting debugging, it may run fine once or twice (retry step 6 to recreate)
*** Building to an actual iPad device works fine ***

Actual Results: App crashes back to home screen
Expected Results: App to on a black/blank screen within our custom UIViewController (HomeViewController)


Please let me know if you need any other details.
Comment 1 Saurabh 2014-08-26 08:22:43 UTC
I have checked this Issue with steps given in this Issue and I am not able to reproduce this Issue. I am successfully able to run application on both iPad device and iPad Simulator. This is the screencast for the same: http://www.screencast.com/t/KynhCv61

@Adam, Could you please check it again and provide me that project for which you are getting this crash?

=== Xamarin Studio ===

Version 5.2 (build 386)
Installation UUID: ff0c16c6-3c75-46d8-ac56-56c3b56e2c76
Runtime:
	Mono 3.6.0 ((no/80b4f74)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 306000040

=== Xamarin.Android ===

Version: 4.14.0 (Business Edition)
Android SDK: /Users/360_macmini/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		3.2   (API level 13)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.3   (API level 18)
		4.4   (API level 19)
Java SDK: /usr
java version "1.7.0_65"
Java(TM) SE Runtime Environment (build 1.7.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Apple Developer Tools ===

Xcode 5.1.1 (5085)
Build 5B1008

=== Xamarin.iOS ===

Version: 7.2.6.28 (Business Edition)
Hash: 606f31a
Branch: 
Build date: 2014-08-01 15:27:48-0400

=== Xamarin.Mac ===

Version: 1.8.1.6

=== Build Information ===

Release ID: 502000386
Git revision: e6a54dee5376e6e7a2d9982695b060fddc09e65d
Build date: 2014-08-04 14:03:28-04
Xamarin addins: 2b5a5c26ac2ee74c6e91a8d24ef44d0ca9cb74d0

=== Operating System ===

Mac OS X 10.9.4
Darwin Apples-iMac.local 13.3.0 Darwin Kernel Version 13.3.0
    Tue Jun  3 21:27:35 PDT 2014
    root:xnu-2422.110.17~1/RELEASE_X86_64 x86_64
Comment 3 adam 2014-08-28 15:37:51 UTC
I've also done a screen recording of the crash, the first two runs crash, and the final two run fine which show the inconsistencies I am experiencing.

http://adamzucchi.com/stage/xamarin/ipadsimulatorcrash/index.html

Thanks!

Adam
Comment 4 Rolf Bjarne Kvinge [MSFT] 2014-09-09 07:42:39 UTC
Can you get the version information from Xamarin Studio's About menu (click on the details button)?

Also check in the system console (Applications -> Utilities -> Console)'s "All messages" list to see if anything is printed when the app crashes.
Comment 5 adam 2014-09-14 14:51:13 UTC
Xamarin Studio - About Xamarin Studio - Show Details
=== Xamarin Studio ===

Version 5.2.1 (build 1)
Installation UUID: a96dd358-fbc6-43e7-9caa-da33558c5490
Runtime:
	Mono 3.6.0 ((no/f540f8a)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 306000039

=== Xamarin.Android ===

Not Installed

=== Apple Developer Tools ===

Xcode 5.1.1 (5085)
Build 5B1008

=== Xamarin.iOS ===

Version: 7.2.6.28 (Indie Edition)
Hash: 606f31a
Branch: 
Build date: 2014-08-01 15:27:48-0400

=== Xamarin.Mac ===

Version:

=== Build Information ===

Release ID: 502010001
Git revision: d06832ce9807d6be24aca225457e8b37c7669f6f
Build date: 2014-08-07 12:10:47-04
Xamarin addins: 1de032531be4cecf2f39dbee3b87aac78204058c

=== Operating System ===

Mac OS X 10.9.4
Darwin a2zs-MacBook-Pro-2.local 13.3.0 Darwin Kernel Version 13.3.0
    Tue Jun  3 21:27:35 PDT 2014
    root:xnu-2422.110.17~1/RELEASE_X86_64 x86_64

------------------------------------------

Console Message:
I've included a new attachment (iPad_Simulator_Crash_Log.log).
Comment 6 adam 2014-09-14 14:51:40 UTC
Created attachment 8060 [details]
iPad_Simulator_Crash_Log
Comment 7 Rolf Bjarne Kvinge [MSFT] 2014-09-17 12:04:27 UTC
I can't reproduce this.

Does it happen with the Xamarin.iOS versions from the alpha or beta channels as well?
Comment 8 adam 2014-09-17 12:08:47 UTC
Good question, that I do not know - I've only been working with the stable releases.  Let's just chalk it up as some oddity with my machine then.  If I have to I will uninstall and reinstall Xamarin Studio and or reformat my Mac with a new install of OS X.
Comment 9 Rolf Bjarne Kvinge [MSFT] 2014-09-17 12:13:22 UTC
Xamarin.iOS 8.0 will be released to the stable channel today or tomorrow, might be easier to try that before reformatting your machine.
Comment 10 adam 2014-09-17 12:14:16 UTC
Good call, thanks again for your help!
Comment 11 Sebastien Pouliot 2016-05-25 00:53:10 UTC
We have never been able to reproduce the issue. 

If you are still experiencing this issue please provide all the requested information and re-open the bug report. Thanks!