Bug 22318 - Confirm whether the "Configuration Manager -> Deploy" checkboxes are meant to be disabled for Xamarin.iOS projects
Summary: Confirm whether the "Configuration Manager -> Deploy" checkboxes are meant to...
Status: RESOLVED FEATURE
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Release Readiness ()
Version: 3.5
Hardware: PC Windows
: --- minor
Target Milestone: 3.5
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-08-22 18:50 UTC by Brendan Zagaeski (Xamarin Team, assistant)
Modified: 2014-08-25 14:43 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Screenshot of configuration manager (26.79 KB, image/png)
2014-08-22 18:50 UTC, Brendan Zagaeski (Xamarin Team, assistant)
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FEATURE

Description Brendan Zagaeski (Xamarin Team, assistant) 2014-08-22 18:50:05 UTC
Created attachment 7779 [details]
Screenshot of configuration manager

Confirm whether the "Configuration Manager -> Deploy" checkboxes are meant to be disabled for Xamarin.iOS projects in Xamarin 3.5 (see attached screenshot).


This is just a quick little request to double-check that the "Configuration -> Deploy" checkboxes were intentionally disabled for Xamarin.iOS projects in Xamarin 3.5.


This makes good sense to me since the Deploy checkbox wasn't really helpful for Xamarin.iOS projects in older versions of XamarinVS, but I just wanted to make sure it was intentional.


Thanks!
Comment 2 Adrian Alonso 2014-08-23 17:32:04 UTC
Yes, it was intentional. You still have the Deploy command (@ solution explorer) for devices in case you want to deploy the app in the device without running. But other than that, it does not make sense to have the deploy thing because it's automatically done by the new targets.
Comment 3 Brendan Zagaeski (Xamarin Team, assistant) 2014-08-25 14:43:40 UTC
Sounds perfect. Thanks!