Bug 22246 - Entry in Grid nested in ViewCell isn't expanding on WP
Summary: Entry in Grid nested in ViewCell isn't expanding on WP
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.2.2
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-08-21 03:22 UTC by bernhard.lang
Modified: 2014-09-10 04:15 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
demo (77.88 KB, application/x-zip-compressed)
2014-08-21 03:22 UTC, bernhard.lang
Details
screenshot (13.52 KB, image/png)
2014-08-21 03:23 UTC, bernhard.lang
Details
screenshot with background (14.27 KB, image/png)
2014-08-21 03:23 UTC, bernhard.lang
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description bernhard.lang 2014-08-21 03:22:23 UTC
Created attachment 7750 [details]
demo

We want to shwo a Entry and Button side by side in a TableView but the Entry isn't expanding as expected.
See the attached screenshots and demo.
The Entry expands when it's shown outside a TableView (not tested in ListView)

When setting the BackgroundColor it seems like it is expanding but the inner TextBox isn't resized.
Comment 1 bernhard.lang 2014-08-21 03:23:02 UTC
Created attachment 7751 [details]
screenshot
Comment 2 bernhard.lang 2014-08-21 03:23:19 UTC
Created attachment 7752 [details]
screenshot with background
Comment 3 bernhard.lang 2014-08-21 03:25:04 UTC
I forgot to say it is working on iOS and Android.
Tested with Xamarin.Forms 1.2.2 and 1.2.3 pre1
Comment 5 Jason Smith [MSFT] 2014-08-22 14:08:59 UTC
This will be fixed in the upcoming pre-release
Comment 6 bernhard.lang 2014-09-10 04:15:43 UTC
I can confirm that this issue is fixed in 1.2.3-pre2.
I don't change the status to  verified cause I don't know your Bug workflow.