Bug 22225 - ListView shows double-line on iOS when background is black
Summary: ListView shows double-line on iOS when background is black
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.2.3
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-08-20 09:19 UTC by Mitch Milam
Modified: 2015-02-03 13:15 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Sample project (4.93 MB, application/x-zip-compressed)
2014-08-20 09:19 UTC, Mitch Milam
Details
screen shot (51.51 KB, image/png)
2014-08-20 09:20 UTC, Mitch Milam
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Mitch Milam 2014-08-20 09:19:49 UTC
Created attachment 7738 [details]
Sample project

If you change your background to black, you will see a double-line separator in your listview.  One line is white, one is grey.

See attached screen shot for an example.

Also visit this forum thread:

http://forums.xamarin.com/discussion/22599/strange-lines-on-listview-when-change-background-color#latest
Comment 1 Mitch Milam 2014-08-20 09:20:37 UTC
Created attachment 7739 [details]
screen shot
Comment 2 Sunil Kumar 2014-08-20 14:19:33 UTC
We have tried to reproduce this issue and we are also getting the same issue. When we run the attached sample application then we are seeing double-line separator in
listview.  One line is white, one is grey.

Screencast: http://screencast.com/t/zBPdzXBNky

Environment info:
Microsoft Visual Studio Professional 2013
Version 12.0.30501.00 Update 2
Microsoft .NET Framework
Version 4.5.50938
Xamarin   3.5.39.0 (0a92fb56e49ed9add1c78e2c881ab6d71220d50f)
Xamarin.Forms 1.2.3.6246-pre1

Build Host info:
X.iOS 7.4.0.104
Xcode 5.1.1
Comment 3 Rui Marinho 2015-02-03 13:15:22 UTC
This is fixed in 1.3.0 final or newer versions.