Bug 22216 - VS Xamarin.Forms project templates don't provide a __IOS__ compilation symbol
Summary: VS Xamarin.Forms project templates don't provide a __IOS__ compilation symbol
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 3.5
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-08-19 18:50 UTC by Chris Sells
Modified: 2015-10-06 16:54 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Chris Sells 2014-08-19 18:50:52 UTC
By default, if you run the Blank App (Xamarin.Forms Shared or Portable), there isn't a __IOS__ symbol defined in the iOS project. Code inside a #if __IOS__ block isn't executed when the iOS target of the project is run. This is a regression from previous versions.

Here are my versions:

    Microsoft Visual Studio Professional 2013
    Version 12.0.30723.00 Update 3
    Microsoft .NET Framework
    Version 4.5.51641

    Xamarin   3.5.25.0 (fd9f6c6d6de9dd8a23f5bc52d60ec7b31b3dc889)


Forum discussion here: http://forums.xamarin.com/discussion/comment/71475
Comment 1 Arpit Jha 2014-08-26 06:16:58 UTC
I have checked this issue and able to reproduce it.

I have tried following steps to reproduce it.
1.Create a Xamarin forms PCL Appn.
2.Right click on Xamarin.ios Project.
3.Go  to Build in left pane.

I observed that there isn't  Conditional Compilation Symbol defined.

ScreenCast: http://screencast.com/t/Qsh9PS1It

Environment Info:
 XVS 3.5.25.0
Comment 2 Joaquin Jares 2015-10-06 16:54:56 UTC
This is now fixed and should be shipping in the next alpha refresh.