Bug 2209 - Many samples layouts are not compatible with API Level 7
Summary: Many samples layouts are not compatible with API Level 7
Status: VERIFIED NOT_ON_ROADMAP
Alias: None
Product: Android
Classification: Xamarin
Component: General ()
Version: 4.0
Hardware: All All
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-11-28 03:06 UTC by Jatin
Modified: 2013-06-24 10:20 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Screenshot for the bug. (316.06 KB, image/jpeg)
2011-11-28 03:06 UTC, Jatin
Details
Screen Shot (169.18 KB, image/tiff)
2011-11-28 08:33 UTC, narayanp
Details
Screen Shot (190.10 KB, image/tiff)
2011-11-28 11:13 UTC, narayanp
Details
Screen Shot Textured cube (179.37 KB, image/tiff)
2011-11-28 11:27 UTC, narayanp
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED NOT_ON_ROADMAP

Description Jatin 2011-11-28 03:06:49 UTC
Created attachment 953 [details]
Screenshot for the bug.

Step To Reproduce:

1.Launch the MonoDevelop.
2.Click on "Start a New Solution" link.
3.Choose C# > Mono for Android in left hand panel.
4.Select Mono for Android Application from the center panel.
5.Open the solution for the sample application Buttons.
6.Set Target Framework dropdown to Mono for Android 2.1. 
8.Build the application.
9.Observe that error appears.

Actual result:
After setting Target Framework dropdown to Mono for Android 2.1, when build the
application 'Contact Manager', it gives the error. Refer to the attached
screenshot.

Expected result:
Error should not appear and the application should build and run successfully.

Environment:
MonoDevelop 2.8.2 with Addin 3.9.9.4
Mono for Android 4.0
Windows 7
Mac 10.6 (Snow Leopard)
Mac 10.7 (Lion)
Comment 1 narayanp 2011-11-28 06:35:04 UTC
This issue exists with SnowLeopard also on API7.
Comment 2 narayanp 2011-11-28 07:02:53 UTC
This Issue also exists with the appllication "HoneyCombGallery" when we run this app on API7 and API10.
Comment 3 narayanp 2011-11-28 08:32:42 UTC
This Issue also exists with the appllication "HoneyCombGallery" when we run
this app on API7. Please refer to screen shot "GoogleMap error"
Comment 4 narayanp 2011-11-28 08:33:37 UTC
Created attachment 956 [details]
Screen Shot
Comment 5 narayanp 2011-11-28 11:13:50 UTC
Created attachment 960 [details]
Screen Shot
Comment 6 narayanp 2011-11-28 11:14:39 UTC
This issue also exists with application "Snake". please refer to screen shot "Snake Issue".
Comment 7 narayanp 2011-11-28 11:27:24 UTC
Created attachment 961 [details]
Screen Shot Textured cube
Comment 8 narayanp 2011-11-28 11:29:03 UTC
This issue also exists with application "Textured Cube". please refer to screen shot "Screen Shot Textured cube".
Comment 9 Atin 2011-11-29 11:13:02 UTC
This issue is also occurring when we RUN the Contact Manager application in API 7 target framework .
Comment 10 Atin 2011-12-05 05:47:33 UTC
We RUN the Snake application on API 7 in Emulator in Debug/Release mode in Target frame work and got the belwo errors:

/Library/Frameworks/Mono.framework/External/xbuild/Novell/Novell.MonoDroid.Common.targets: Error: Tool exited with code: 1. Output: /Users/imac/Desktop/30 Nov/xamarin-monodroid-samples-35a872e/xamarin-monodroid-samples-35a872e/Snake/obj/Debug/res/layout/snake_layout.xml:14: error: Error: String types not allowed (at 'layout_width' with value 'match_parent').
/Users/imac/Desktop/30 Nov/xamarin-monodroid-samples-35a872e/xamarin-monodroid-samples-35a872e/Snake/obj/Debug/res/layout/snake_layout.xml:14: error: Error: String types not allowed (at 'layout_height' with value 'match_parent').
/Users/imac/Desktop/30 Nov/xamarin-monodroid-samples-35a872e/xamarin-monodroid-samples-35a872e/Snake/obj/Debug/res/layout/snake_layout.xml:14: error: Error: String types not allowed (at 'layout_width' with value 'match_parent').
/Users/imac/Desktop/30 Nov/xamarin-monodroid-samples-35a872e/xamarin-monodroid-samples-35a872e/Snake/obj/Debug/res/layout/snake_layout.xml:14: error: Error: String types not allowed (at 'layout_height' with value 'match_parent').
/Users/imac/Desktop/30 Nov/xamarin-monodroid-samples-35a872e/xamarin-monodroid-samples-35a872e/Snake/obj/Debug/res/layout/snake_layout.xml:14: error: Error: String types not allowed (at 'layout_width' with value 'match_parent').
/Users/imac/Desktop/30 Nov/xamarin-monodroid-samples-35a872e/xamarin-monodroid-samples-35a872e/Snake/obj/Debug/res/layout/snake_layout.xml:14: error: Error: String types not allowed (at 'layout_height' with value 'match_parent').
 (Snake)




Environments:
MAC 10.6 (Snow Leopard)
Mono for Android 4.0-1
Mono Develop 2.8.4
Comment 11 Saurabh 2011-12-13 04:14:25 UTC
This Issue exists with the application "APIDEMO" when we run
this app on API7 at Debug/Release mode.
Comment 12 Saurabh 2011-12-13 05:01:26 UTC
This Issue exists with the application "APIDEMO" when we run
this app on API7 at Debug/Release mode.

Environment:

MT - 5.0.4
MD - 2.8.5
M4A - 4.0.1
Comment 13 Saurabh 2011-12-13 05:02:28 UTC
Please consider Ciontact Manager in stead of APIDemo in above comment.
Comment 14 Saurabh 2011-12-13 07:41:26 UTC
This Issue exists with the application "MapsDemo" when we run
this app on API7 at Debug/Release mode.

Environment:

MT - 5.0.4
MD - 2.8.5
M4A - 4.0.1
Comment 16 Jonathan Pobst 2012-04-25 16:19:26 UTC
API7 is pretty much dead (6%).  While we should still fix real bugs with API7, let's not waste resources on ensuring our samples run on API7.  These layouts use API8 features that are not supported on API7.
Comment 17 Atin 2013-06-24 10:20:01 UTC
As per comment 16, this issue is invalid.

Hence closing this issue. Changing its status to verified.