Bug 22083 - Running a Task leaks
Summary: Running a Task leaks
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: master
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-08-13 18:32 UTC by emuye.taylor
Modified: 2016-05-25 00:46 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
test app that leaks (7.26 KB, application/zip)
2014-08-13 18:32 UTC, emuye.taylor
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description emuye.taylor 2014-08-13 18:32:12 UTC
Created attachment 7685 [details]
test app that leaks

I've attached a test app which when you hit a button runs a new task (adds numbers) and upon completion swaps a view. The first time the task is run the app leaks.
Comment 1 Parmendra Kumar 2014-08-20 10:25:42 UTC
I have tried to reproduce this issue with following steps:
1. Run the attached sample project .
2. Open Instruments.
3. Choose leaks.
4. Select device and application. 
5. Click to record trace.

I observed that the Leaks is generate. But it does't generate every time. 

Screencast: http://screencast.com/t/8qiIfoc5pap

Environment info:

=== Xamarin Studio ===

Version 5.2.1 (build 1)
Installation UUID: 1a096c6f-0678-402e-89b2-a2c10f7e80e4
Runtime:
	Mono 3.6.0 ((no/f540f8a)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 306000039

=== Xamarin.Android ===

Version: 4.14.0 (Business Edition)
Android SDK: /Users/360_macmini/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		3.2   (API level 13)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.3   (API level 18)
		4.4   (API level 19)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

=== Apple Developer Tools ===

Xcode 5.1 (5084)
Build 5B130a

=== Xamarin.iOS ===

Version: 7.2.6.28 (Business Edition)
Hash: 606f31a
Branch: 
Build date: 2014-08-01 15:27:48-0400

=== Xamarin.Mac ===

Version: 1.10.0.4 (Business Edition)

=== Build Information ===

Release ID: 502010001
Git revision: d06832ce9807d6be24aca225457e8b37c7669f6f
Build date: 2014-08-07 12:10:47-04
Xamarin addins: 1de032531be4cecf2f39dbee3b87aac78204058c

=== Operating System ===

Mac OS X 10.9.4
Comment 2 emuye.taylor 2014-08-27 16:37:20 UTC
Yes, I mentioned in the description, it only leaks the first time.
Comment 3 emuye.taylor 2014-08-27 16:41:01 UTC
I believe the completion of the task causes the thread to return to the thread pool. If a new thread was spun up to complete the task it would leak every time. I tested this by not allowing the task to complete.
Comment 4 Rolf Bjarne Kvinge [MSFT] 2014-09-22 09:45:22 UTC
I can't reproduce any leaks with Xamarin.iOS 8.0 and the steps from comment #1.

If you can still reproduce a leak with Xamarin.iOS 8.0, please attach the trace from Instruments and explain exactly the steps that created the trace.
Comment 5 Parmendra Kumar 2014-09-22 11:09:47 UTC
Hi Rolf Bjarne,
                       I have checked this issue with Xamarin.iOS 8.0, And Now It's not generate any leak.
It is working fine at my end.
Comment 6 Sebastien Pouliot 2016-05-25 00:46:19 UTC
We could not duplicate the issue (see comment #4).

If you are still experiencing this issue please provide all the requested information and re-open the bug report. Thanks!