Bug 22081 - Can't add a Component to an iOS or Android project in a newly created Xamarin Forms PCL or Shared solution
Summary: Can't add a Component to an iOS or Android project in a newly created Xamarin...
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Xamarin.Forms ()
Version: 3.3
Hardware: PC Windows
: High major
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-08-13 17:06 UTC by Jon Goldberger [MSFT]
Modified: 2015-08-04 10:00 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Jon Goldberger [MSFT] 2014-08-13 17:06:45 UTC
To reproduce:

1. Open Visual Studio 2012 Update 2
2. Create a new Blank App (Xamarin.Forms Shared) project or Blank App (Xamarin.Forms Portable) project
3. Right click on the Components folder in either the Android or IOS project and select "Get more Components"
4. Add the SignalR (or any other) component

Expected result: Component will be added and references for the component will be in the References folder.
Actual Result: A popup appears saying "Web Page cannot be displayed" and (Unresolved) appears next to the Component name in the Components folder. 

See screencast: http://screencast.com/t/cZYN702zd

Workarounds:
Closing and re-opening the solution before trying to add the component allows the component to be added as expected when the solution is re-opened.

Closing and re-opening the solution after trying to add the component resolves the issue, i.e. the component is in the Components folder without the "Unresolved" message and the component is referenced in the References folder.
Comment 1 Jon Goldberger [MSFT] 2014-08-13 17:07:12 UTC
Note: This works as expected in Xamarin Studio on the Mac.
Comment 2 Udham Singh 2014-08-14 02:30:12 UTC
I have checked this issue and able to reproduce this. To reproduce this issue I have followed the steps mentioned in bug description. I have checked this issue with Xamarin version 3.3.47.0 and 3.5.30.0 and getting same behavior with both versions.

Screencast : http://www.screencast.com/t/U9IlM9igj

Environment Info : 

VS 2013
Xamarin 3.3.47.0 and 3.5.30.0
Xamarin.iOS Build Host 7.2.6.28
Comment 3 Daniel Cazzulino 2015-07-29 11:17:10 UTC
Assigning to Enzo to verify/close, since I don't think this happens anymore.
Comment 4 Enzo Heredia 2015-08-04 10:00:59 UTC
can't reproduce 4.0.0.796