Bug 21983 - No error when defining several destructors in partial classes
Summary: No error when defining several destructors in partial classes
Status: RESOLVED FIXED
Alias: None
Product: Compilers
Classification: Mono
Component: C# ()
Version: 3.2.x
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2014-08-10 12:41 UTC by ssundermann
Modified: 2014-08-13 14:21 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description ssundermann 2014-08-10 12:41:23 UTC
This compiles on mono, but throws an error on .NET because a destructor is already defined.

File1.cs

using System;

namespace Test
{
	public partial class EmptyClass
	{
		~EmptyClass () {
			// Do stuff here
		}
	}
}

File2.cs

using System;

namespace Test
{
	public partial class EmptyClass
	{
		~EmptyClass () {
			// Do stuff here
		}
	}
}
Comment 1 Marek Safar 2014-08-13 14:21:25 UTC
Fixed in master