Bug 21804 - Unhandled Activation Error
Summary: Unhandled Activation Error
Status: RESOLVED INVALID
Alias: None
Product: Android
Classification: Xamarin
Component: Tools and Addins ()
Version: 4.14.0
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2014-08-04 18:03 UTC by Andrew Page
Modified: 2017-06-27 18:22 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description Andrew Page 2014-08-04 18:03:21 UTC
Started up my laptops copy of Xam Studio and I received an "Unhandled Activation Error" with a request to send this:


System.Exception: Could not load machine data: monodroid: error XA0000: Unexpected error - Please file a bug report at http://bugzilla.xamarin.com. Reason: System.Xml.XmlException: Document element did not appear.  Line 1, position 1.
  at Mono.Xml2.XmlTextReader.Read () [0x00000] in <filename unknown>:0 
  at System.Xml.XmlTextReader.Read () [0x00000] in <filename unknown>:0 
  at System.Xml.XmlDocument.ReadNodeCore (System.Xml.XmlReader reader) [0x00000] in <filename unknown>:0 
  at System.Xml.XmlDocument.ReadNode (System.Xml.XmlReader reader) [0x00000] in <filename unknown>:0 
  at System.Xml.XmlDocument.Load (System.Xml.XmlReader reader) [0x00000] in <filename unknown>:0 
  at System.Xml.XmlDocument.LoadXml (System.String xml) [0x00000] in <filename unknown>:0 
  at Xamarin.Licensing.PlatformActivation.TransformSystemProfilerOutput (System.String systemProfilerXml) [0x00000] in <filename unknown>:0 
  at Xamarin.Licensing.PlatformActivation.GetRegistrationXml (Mono.Touch.Activation.Common.License license) [0x00000] in <filename unknown>:0 
  at Xamarin.Licensing.PlatformActivation.ShowDataFile () [0x00000] in <filename unknown>:0 
  at Xamarin.Licensing.PlatformActivation.ProcessOptions () [0x00000] in <filename unknown>:0 
  at Monodroid.Arguments.Parse (IEnumerable`1 argv) [0x00000] in <filename unknown>:0 
  at Monodroid.MainClass.Main (System.String[] argv) [0x00000] in <filename unknown>:0
  at Xamarin.Components.Ide.Activation.ActivationHandler+<LoadMachineData>c__AnonStoreyA.<>m__0 (System.Threading.Tasks.Task`1 t) [0x00045] in /Users/builder/data/lanes/1089/7d45bbe2/source/md-addins/Xamarin.Ide/Xamarin.Components.Ide/Activation/ActivationHandler.cs:671 
  at System.Threading.Tasks.TaskActionInvoker+FuncTaskInvoke`2[System.Int32,System.String].Invoke (System.Threading.Tasks.Task owner, System.Object state, System.Threading.Tasks.Task context) [0x00000] in /Volumes/build-root-ramdisk/mono-3.4.0/mcs/class/corlib/System.Threading.Tasks/TaskActionInvoker.cs:330 
  at System.Threading.Tasks.Task.InnerInvoke () [0x00019] in /Volumes/build-root-ramdisk/mono-3.4.0/mcs/class/corlib/System.Threading.Tasks/Task.cs:550 
  at System.Threading.Tasks.Task.ThreadStart () [0x000d0] in /Volumes/build-root-ramdisk/mono-3.4.0/mcs/class/corlib/System.Threading.Tasks/Task.cs:438
Comment 1 Rajneesh Kumar 2014-08-05 03:26:55 UTC
Hi Andrew,
I have checked this issue and unable to reproduce. Could you please let me know that which type of version you are using? so that  I can reproduce this issue at my end. 
This is the screencast for the same: http://www.screencast.com/t/KgXbEdAY
In my  case I have used Trial license.

Environment Info:
Xamarin Studio
Version 5.2 (build 386)

Git revision: e6a54dee5376e6e7a2d9982695b060fddc09e65d

Xamarin.Android
Version: 4.14.0 (Trial Edition)
Comment 2 Chris Hardy [MSFT] 2017-06-27 18:22:23 UTC
Thank you for taking the time to submit this report. After reviewing the description of this bug, we believe it no longer affects the current version of Xamarin.Android. If you are still experiencing the issue after updating your packages, please reopen this report with an attached reproduction.