Bug 21721 - Exception on real device when integrating Pixate with Xamarin.Forms since 1.1
Summary: Exception on real device when integrating Pixate with Xamarin.Forms since 1.1
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.1.0
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-07-30 20:59 UTC by adslcx
Modified: 2016-03-15 19:38 UTC (History)
6 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description adslcx 2014-07-30 20:59:51 UTC
This is a repost of http://forums.xamarin.com/discussion/comment/66352

"
I mentioned this error in a previous post (http://forums.xamarin.com/discussion/comment/58832/#Comment_58832) but it was left unnoticed, so I'm posting this again with more updates.

Previous post:

I got the error "Failed to find the closed generic method 'InvokeConformsToProtocol' on the type 'Xamarin.Forms.Platform.iOS.FrameRenderer'" when testing my app on a real iPhone but not in the simulator. I haven't been able to come up with a minimum example yet. But is there any interpretation on the error? I don't really know where to start
I have now narrowed down the error due to integration of Pixate with Xamarin.Forms. I created a repo demonstrating the bug here: https://github.com/dementrock/BuggyExample

The project should run just fine on an iOS simulator, but throws the exception when testing on a real device.
"
Comment 1 dhaligas 2014-08-13 10:39:55 UTC
We really need to get pixate working with Xamarin.Forms.  This opens up tons of styling that is needed to make our apps look good.
Comment 2 Saurabh 2014-08-22 03:03:28 UTC
I have check this issue with attached project and observed that when I am using Xamarin.Forms 1.1.x and build iOS project(in attached project), It is giving build error "Error: /Users/nischal/Downloads/BuggyExample-master/test2/test2.csproj: /Users/nischal/Downloads/BuggyExample-master/test2/test2.csproj could not import "../packages/Xamarin.Forms.1.1.0.6201/build/portable-win+net45+wp80+MonoAndroid10+MonoTouch10/Xamarin.Forms.targets" (test2)". However When I have updated Xamarin.Forms to 1.2.2.x and build again iOS project, It is giving 4 build errors, mentioned in gist: https://gist.github.com/saurabh360/f94abe36e198017daf40
 
So I am not able to run iOS application.

@adsicx, Could you please check same again at you end and let me know if you are also getting same Issue with attached same and provide me latest same so that I can reproduce this Issue at my end?

Build which I have used at my end:
X.S 5.2.1 (Build 1)
Git revision: d06832ce9807d6be24aca225457e8b37c7669f6f
X.iOS 7.2.6.28
Comment 3 adslcx 2014-08-22 12:36:01 UTC
Hi Saurabh,

I have updated the repo to use the latest version of Xamarin.Forms and fixed the package issue. Could you give it a try again?
Comment 4 Prashant manu 2014-11-03 06:56:45 UTC
I have tried latest project with current latest builds. I am successfully able to deploy and launch application on real devices. This is the application Output: https://gist.github.com/saurabh360/7c66ea7445442807abd9

X.S 5.5.3(Build 6)
Git revision: fbe3e9453daf6a3bb9a9709ed22bec35f7c9056b
X.iOS 8.4.0-16

@adsick, Please let me know is it working now at your end with latest stable builds?
Comment 5 Jason Smith [MSFT] 2016-03-15 19:38:59 UTC
Thank you for taking the time to submit this report. After reviewing the description of this bug, we no longer believe it affects the current version of Xamarin.Forms. If you are still experiencing the issue after updating your packages, please reopen this report with an attached reproduction.
 
For your convenience, we have created some reproduction best practices viewable here: https://gist.github.com/jassmith/92405c300e54a01dcc6d

Warm regards,
Xamarin Forms Team