Bug 21708 - Error dispayed when try to compile app in VS 2010
Summary: Error dispayed when try to compile app in VS 2010
Status: VERIFIED NOT_ON_ROADMAP
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: 3.0
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: vsx
URL:
Depends on:
Blocks:
 
Reported: 2014-07-30 14:46 UTC by José Roberto
Modified: 2016-09-15 09:04 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED NOT_ON_ROADMAP

Description José Roberto 2014-07-30 14:46:10 UTC
Error	9	Unexpected error - Please file a bug report at http://bugzilla.xamarin.com. Reason: System.IO.DirectoryNotFoundException: Directory 'D:\projetos SVN\CRC\Trunk\6-Construção\Código Fonte\CRC Mobile\CRC_Mobile_AND\bin\Debug' not found.	CRC_Mobile_AND

The error described above occurs in my work development environment, I think it occurs becouse the folders name, but I can't change the names.
How can I fix it without change names?
Comment 1 Rajneesh Kumar 2014-07-31 02:36:10 UTC
Please refer to bug https://bugzilla.xamarin.com/show_bug.cgi?id=14918 regarding this. 
As per my knowledge, there is only workaround for this issue is that you have to rename your folder name. 

we have to see, may be developer will help you to provide any other solution.
Comment 2 Rajneesh Kumar 2015-07-14 13:59:17 UTC
I have checked this issue with latest stable build XVS 3.11.666 + XI 8.10.3.2 and observed that this issue still exist.

Screencast: http://www.screencast.com/t/RVGUPs7HaB8r

Note: "TRIAL" and "STARTER" user is unable to build the android project
which contains unicode characters in Solution name or solution path folder
name. However, useris able to build the application using Business and Enterprise licence.

Also please have a look on following bug, comment 3
https://bugzilla.xamarin.com/show_bug.cgi?id=27076#c3

Thanks..!

Environment Info:

Microsoft Visual Studio Professional 2013
Version 12.0.31101.00 Update 4
Microsoft .NET Framework
Version 4.5.50938
Installed Version: Professional
Xamarin   3.11.666.0 (ebae43a)
Visual Studio extension to enable development for Xamarin.iOS and
Xamarin.Android.
Xamarin.Android   5.1.4.16 (5f55a9ef61c11b6ce0890bc91e4c71b1b92be214)
Visual Studio plugin to enable development for Xamarin.Android.
Xamarin.iOS   8.10.2.0 (67b390d0d1bd741582cf7b7fd3ffea08583a3f83)
Visual Studio extension to enable development for Xamarin.iOS.
Comment 3 Enzo Heredia 2015-10-20 11:09:16 UTC
This is fixed in alpha version.