Bug 21632 - TableView Instability in android
Summary: TableView Instability in android
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.0.6188
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-07-28 11:06 UTC by petergoddard1960
Modified: 2016-03-15 19:35 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
TestApplication (2.52 MB, application/x-zip-compressed)
2014-07-28 11:11 UTC, petergoddard1960
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description petergoddard1960 2014-07-28 11:06:28 UTC
Dynamically generating a table view causes UI instabilities in Android.

The attached sample has been tested on three different versions of android. All small screen smartphones. The controls inside the UI are randomly disappearing from view and the Entry UI elements are not functioning correctly, losing the ability to focus in portrait mode.

I need to solve this issue urgently, as a customer project is now pressing.
Comment 1 petergoddard1960 2014-07-28 11:11:03 UTC
Created attachment 7507 [details]
TestApplication
Comment 2 Arpit Jha 2014-08-21 07:56:28 UTC
I have checked this issue and observed that when i run  Entry Example application UI was looking as expected and scroll is also functioning properly.Please clarify that UI are randomly disappearing.

Screecast: http://screencast.com/t/RqkCs6aTz

Environment Info: 
XVS 3.3.47.0

Xamarin version : 
1.2.2.6243

Additional Info:
Checked on Emulator API18

Let me know if i missed anything.
Comment 3 Jason Smith [MSFT] 2016-03-15 19:35:45 UTC
Thank you for taking the time to submit this report. After reviewing the description of this bug, we no longer believe it affects the current version of Xamarin.Forms. If you are still experiencing the issue after updating your packages, please reopen this report with an attached reproduction.
 
For your convenience, we have created some reproduction best practices viewable here: https://gist.github.com/jassmith/92405c300e54a01dcc6d

Warm regards,
Xamarin Forms Team