Bug 21549 - Resource.designer.cs file is not recreated
Summary: Resource.designer.cs file is not recreated
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild ()
Version: 5.1
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: dean.ellis
URL:
Depends on:
Blocks:
 
Reported: 2014-07-23 12:14 UTC by silvano.babini
Modified: 2017-06-27 18:15 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description silvano.babini 2014-07-23 12:14:57 UTC
Resource.designer.cs file is not recreated when modify/add layouts so device and code not recognize new resources. 
Cleaning/Building project no errors are showed, but new layout is missing in the code. I'm getting this problem after update to version 5.1.0. Now I use 5.1.4 but not work for me. I'm not sure it's an error of my project or a bug of Xamarin Studio because no errors are showed.
Comment 1 Parmendra Kumar 2014-07-23 14:24:26 UTC
I have checked this issue as given steps
I observed that the resource.designer.cs file is update when modify/add layout

ScreenCast:http://www.screencast.com/t/jIlNbus3L

let us know if you still face any problem.

Environment:
=== Xamarin Studio ===

Version 5.1.4 (build 0)
Installation UUID: 917f9508-3cad-494a-8fd9-cc9e3683ecc5
Runtime:
	Microsoft .NET 4.0.30319.34014
	GTK+ 2.24.22 (MS-Windows theme)
	GTK# 2.12.25

=== Xamarin.Android ===

Version: 4.12.6 (Business Edition)
Android SDK: D:\SDKndk\AndroidSDK\android-sdk
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.4   (API level 19)
Java SDK: C:\Program Files\Java\jdk1.6.0_31
java version "1.6.0_31"
Java(TM) SE Runtime Environment (build 1.6.0_31-b05)
Java HotSpot(TM) Client VM (build 20.6-b01, mixed mode)

=== Build Information ===

Release ID: 501040000
Git revision: 7d45bbe2ee22625f125d0c52548524f02d005cca
Build date: 2014-07-14 13:38:46-04
Xamarin addins: c78f1d88e57baa928aeee1484d96e6f8edf8de33

=== Operating System ===

Windows 6.2.9200.0
Comment 2 Chris Hardy [MSFT] 2017-06-27 18:15:53 UTC
Unfortunately, we’re unable to reproduce this report. If this issue is still occurring for you, please reopen this issue and attach a reproduction to the bug by starting with a clean Xamarin.Android project adding just the code necessary to demonstrate the issue.