Bug 21483 - Setting VisualElement BackgroundColorProperty to Color Transparent does not work
Summary: Setting VisualElement BackgroundColorProperty to Color Transparent does not work
Status: RESOLVED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.2.2
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-07-21 12:55 UTC by John Miller [MSFT]
Modified: 2016-03-15 19:28 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description John Miller [MSFT] 2014-07-21 12:55:58 UTC
### Overview: 

    Setting VisualElement.BackgroundColorProperty to Color.Transparent no longer works. Checked in 1.2.2.6238-pre1.

### Steps to Reproduce: 

    public class DarkTextCell : ImageCell
    {
    }
    //...

    var cell = new DataTemplate(typeof(DarkTextCell));
    cell.SetValue(VisualElement.BackgroundColorProperty, Color.Transparent);

### Actual Results: 

    The cell background is still white. 

### Expected Results: 

    The cell background should be transparent.

### Build Date & Platform: 

    XF 1.2.2.6238-pre1

### Additional Information: 

    This did work in a previous version. (Might have been 1.1.1)
Comment 1 John Miller [MSFT] 2014-07-23 13:48:42 UTC
Still an issue in 1.2.2.6240-pre2.
Comment 3 Ram Chandra 2014-08-20 09:35:13 UTC
I have checked this issue but I am unable to reproduce this issue.

Steps I followed:

1. Create an  Blank App ( Xamarin.Forms Portable) on XS.
2. Add a new Content Page on XS.
3. Write the following code on newly added Content page.
    
     public partial class MyPage : ContentPage
	{	
        public MyPage()
        {
            Label header = new Label
            {
                Text = "TextCell",
                Font = Font.BoldSystemFontOfSize(50),
                HorizontalOptions = LayoutOptions.Center
            };

            TableView tableView = new TableView
            {
                Intent = TableIntent.Form,
                Root = new TableRoot
                {
                    new TableSection
                    {
                        new TextCell
                        {
                            Text = "This is a TextCell",
                            Detail = "This is some detail text",
                        }
                    }
                }
            };

            tableView.SetValue(VisualElement.BackgroundColorProperty, Color.Transparent);
            this.Padding = new Thickness(10, Device.OnPlatform(20, 0, 0), 10, 5);
            this.Content = new StackLayout
            {
                Children = 
                {
                    header,
                    tableView
                }
                };
        }
	}

4. Call the newly added content page from app.cs file
    
     return new MyPage();

To check this issue I have set the VisualElement.BackgroundColorProperty to Color.Transparent  and I observed that it is working and I am able to set the VisualElement.BackgroundColorProperty to Color.Transparent . I have also try to set few colors and I am also able to set background color.

Checked with: 1.2.2.6243

Screencast: http://www.screencast.com/t/sqm8sWrMU7K

Could you please provide me test steps or sample application and environment info?  So, that we can reproduce this issue.

Environment Info: 

=== Xamarin Studio ===

Version 5.2.1 (build 1)
Installation UUID: 011d70a5-dede-428b-ab04-ef451c2e539d
Runtime:
	Mono 3.8.0 ((no/62a857e)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 308000007

=== Xamarin.Android ===

Version: 4.14.0 (Enterprise Edition)
Android SDK: /Users/MM/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		3.2   (API level 13)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.3   (API level 18)
		4.4   (API level 19)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

=== Apple Developer Tools ===

Xcode 5.1.1 (5085)
Build 5B1008

=== Xamarin.iOS ===

Version: 7.4.0.102 (Enterprise Edition)
Hash: 141adb9
Branch: 
Build date: 2014-08-15 12:54:28-0400

=== Xamarin.Mac ===

Version: 1.10.0.4 (Enterprise Edition)

=== Build Information ===

Release ID: 502010001
Git revision: d06832ce9807d6be24aca225457e8b37c7669f6f
Build date: 2014-08-07 12:10:47-04
Xamarin addins: 1de032531be4cecf2f39dbee3b87aac78204058c

=== Operating System ===

Mac OS X 10.9.2
Darwin MacMini.local 13.1.0 Darwin Kernel Version 13.1.0
    Thu Jan 16 19:40:37 PST 2014
    root:xnu-2422.90.20~2/RELEASE_X86_64 x86_64
Comment 4 Jason Smith [MSFT] 2016-03-15 19:28:34 UTC
Thank you for taking the time to submit this report. After reviewing the description of this bug, we no longer believe it affects the current version of Xamarin.Forms. If you are still experiencing the issue after updating your packages, please reopen this report with an attached reproduction.
 
For your convenience, we have created some reproduction best practices viewable here: https://gist.github.com/jassmith/92405c300e54a01dcc6d

Warm regards,
Xamarin Forms Team