Bug 21448 - Don't show "Connection to Xamarin.iOS Build Host failed" if another project is currently the start-up project
Summary: Don't show "Connection to Xamarin.iOS Build Host failed" if another project i...
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 3.3
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Pierce Boggan [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2014-07-18 15:43 UTC by Pierce Boggan [MSFT]
Modified: 2015-09-28 14:09 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Pierce Boggan [MSFT] 2014-07-18 15:43:42 UTC
Description of Issue: When you have a solution referencing multiple platforms (like Android, iOS, and Windows Phone) the Mac Build Host error shouldn't appear. It is confusing from a user's perspective and gives the perception that something is wrong, even though it isn't (unless they are targeting iOS).

Screencast: http://screencast.com/t/I1GbBp5F
Comment 1 Sadik Ali 2014-07-21 07:50:08 UTC
I have checked this issue and I am getting the same behavior

When I create xamarin.Forms application on VS I observed that I am getting the same error while my Startup project is Android or Windows not iOS.

Screencast: http://www.screencast.com/t/PIm5EYIY

Environment Info:

Windows 8.1
Microsoft Visual Studio Professional 2013
Version 12.0.30501.00 Update 2
Microsoft .NET Framework
Version 4.5.51641
Installed Version: Professional
Xamarin   3.3.43.0 (2c7ce396ab0b65e4a494d3055402ed5b33912ce2)
Comment 2 Enzo Heredia 2015-09-28 14:09:47 UTC
With implementation of XMA this shouldn't be reproducible, please verify with latest master build or alpha.