Bug 21442 - WebView crash
Summary: WebView crash
Status: RESOLVED NORESPONSE
Alias: None
Product: Android
Classification: Xamarin
Component: General ()
Version: 4.5.x
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2014-07-18 11:48 UTC by Denis
Modified: 2017-06-27 18:14 UTC (History)
3 users (show)

Tags: WebView
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description Denis 2014-07-18 11:48:34 UTC
When i try to load "http://vk.com" in a WebView something goes wrong, but with other URLs it's Ok. I use Nexus 5 and Anfroid L.

Forwarding debugger port 8898
Detecting existing process
Loaded assembly: afvcks0.dll
Loaded assembly: Mono.Android.dll [External]
Loaded assembly: System.Core.dll [External]
Loaded assembly: MonoDroidConstructors [External]
[art] Late-enabling -Xcheck:jni
[art] Profiler disabled.  To enable setprop dalvik.vm.profiler 1
[libc] WARNING: generic atexit() called from legacy shared library
[Mono] Image addref mscorlib[0xb76ed1a0] -> mscorlib.dll[0xb76d9a48]: 1
[Mono] AOT module 'mscorlib.dll.so' not found: dlopen failed: library "/data/data/afvcks0.afvcks0/lib/mscorlib.dll.so" not found
[Mono] Assembly mscorlib[0xb76ed1a0] added to domain RootDomain, ref_count=1
[art] Thread[14,tid=337,Native,Thread*=0xb7723c18,peer=0x78482080,"Thread-12177"] attached without supplying a name
[art] Thread[15,tid=339,Native,Thread*=0xb7726758,peer=0x7848c080,"Thread-12178"] attached without supplying a name
[Mono] Image addref afvcks0[0xb7727b80] -> afvcks0.dll[0xb7727280]: 1
[Mono] Assembly afvcks0[0xb7727b80] added to domain RootDomain, ref_count=1
[Mono] AOT module 'afvcks0.dll.so' not found: dlopen failed: library "/data/data/afvcks0.afvcks0/lib/afvcks0.dll.so" not found
[monodroid-gc] GREF GC Threshold: 46800
[Mono] Image addref Mono.Android[0xb772cd70] -> Mono.Android.dll[0xb772c220]: 1
[Mono] Assembly Mono.Android[0xb772cd70] added to domain RootDomain, ref_count=1
[Mono] AOT module 'Mono.Android.dll.so' not found: dlopen failed: library "/data/data/afvcks0.afvcks0/lib/Mono.Android.dll.so" not found
[Mono] Assembly Ref addref Mono.Android[0xb772cd70] -> mscorlib[0xb76ed1a0]: 2
[Mono] Image addref System.Core[0xb775b6c8] -> System.Core.dll[0xb775aaf8]: 1
[Mono] Assembly System.Core[0xb775b6c8] added to domain RootDomain, ref_count=1
[Mono] AOT module 'System.Core.dll.so' not found: dlopen failed: library "/data/data/afvcks0.afvcks0/lib/System.Core.dll.so" not found
[Mono] Assembly Ref addref Mono.Android[0xb772cd70] -> System.Core[0xb775b6c8]: 2
[Mono] Assembly Ref addref System.Core[0xb775b6c8] -> mscorlib[0xb76ed1a0]: 3
[Mono] Assembly Ref addref afvcks0[0xb7727b80] -> Mono.Android[0xb772cd70]: 2
[Mono] DllImport attempting to load: '__Internal'.
[Mono] DllImport loaded library '(null)'.
[Mono] DllImport searching in: '__Internal' ('(null)').
[Mono] Searching for '_monodroid_gc_wait_for_bridge_processing'.
[Mono] Probing '_monodroid_gc_wait_for_bridge_processing'.
[Mono] Found as '_monodroid_gc_wait_for_bridge_processing'.
[Mono] DllImport searching in: '__Internal' ('(null)').
[Mono] Searching for '_monodroid_get_identity_hash_code'.
[Mono] Probing '_monodroid_get_identity_hash_code'.
[Mono] Found as '_monodroid_get_identity_hash_code'.
[Mono] Assembly Ref addref afvcks0[0xb7727b80] -> mscorlib[0xb76ed1a0]: 4
[Mono] DllImport searching in: '__Internal' ('(null)').
[Mono] Searching for '_monodroid_gref_log_new'.
[Mono] Probing '_monodroid_gref_log_new'.
[Mono] Found as '_monodroid_gref_log_new'.
[am_on_resume_called] [0,afvcks0.MainActivity]
[CanvasContext] Render dirty regions requested: true
[am_on_paused_called] [0,afvcks0.MainActivity]
[Adreno-GSL] <ioctl_kgsl_device_getproperty:663>: mmap failed: errno 22 Invalid argument
[Adreno-EGL] <qeglDrvAPI_eglInitialize:320>: EGL 1.4 QUALCOMM Build: I10246dbd022c719c705be805d5642cc8fdfbd2a2Date: 03/07/14
[CanvasContext] Initialized EGL, version 1.4
[OpenGLRenderer] Enabling debug mode 0
[WebViewChromiumFactoryProvider] Binding Chromium to main looper Looper (main, tid 1) {2464310}
[LibraryLoader] Expected native library version number "",actual native library version number ""
[chromium] [INFO:library_loader_hooks.cc(106)] Chromium logging enabled: level = 0, default verbosity = 0
[BrowserStartupController] Initializing chromium process, renderers=0
[art] Attempt to remove local handle scope entry from IRT, ignoring
[art] Thread[17,tid=366,Native,Thread*=0xb7a0bc08,peer=0x784f2080,"Thread-12180"] attached without supplying a name
[art] Thread[18,tid=373,Native,Thread*=0xb7a37a80,peer=0x78504080,"Thread-12181"] attached without supplying a name
[art] Thread[19,tid=367,Native,Thread*=0xb7a40390,peer=0x7850e080,"Thread-12182"] attached without supplying a name
[Settings] Setting webview_data_reduction_proxy_key has moved from android.provider.Settings.Secure to android.provider.Settings.Global.
[chromium] [WARNING:proxy_service.cc(904)] PAC support disabled because there is no system implementation
[chromium] [WARNING:data_reduction_proxy_settings.cc(479)] SPDY proxy OFF at startup
[art] Attempt to remove local handle scope entry from IRT, ignoring
[chromium] [WARNING:webrtc_internals.cc(52)] Could not get the download directory.
[am_on_resume_called] [0,afvcks0.AuthA]
[art] Thread[21,tid=386,Native,Thread*=0xb7aeedf0,peer=0x78550080,"Thread-12185"] attached without supplying a name
[art] Thread[22,tid=402,Native,Thread*=0xb7b88c58,peer=0x7855c080,"Thread-12186"] attached without supplying a name
[chromium] [INFO:SkUtilsArm.cpp(179)] Device supports ARM NEON instructions!
[chromium] 
[am_on_paused_called] [0,afvcks0.AuthA]
Comment 1 Prashant manu 2014-07-21 07:33:37 UTC
Could you please provide us the test steps you followed. If possible please
attach a small complete project that demonstrates this behavior.

Also can you please add the logs from the following places?:
On XS IDE Log  Location: XS>Help> Open Log Directory> IDE.log file (with latest
timestamp)
AndroidTools log: XS->Help->Open Log Directory->AndroidTools.log

If using VS, 
IDE log: Location: C:\User\AppData\Local\Xamarin\Log\ 
(Devenev file with latest timestamp)
Android Trace log: Location: \AppData\Local\Xamarin\Log\XamarinAndroid
Comment 2 Chris Hardy [MSFT] 2017-06-27 18:14:07 UTC
Because we have not received a reply to our request for more information we are closing this issue. If you are still encountering this issue, please reopen the ticket with the requested information. Thanks!