Bug 21412 - codegen tests make failure against JDK 8
Summary: codegen tests make failure against JDK 8
Status: RESOLVED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: General ()
Version: 4.14.0
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2014-07-17 18:08 UTC by Peter Collins
Modified: 2014-07-30 06:02 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Peter Collins 2014-07-17 18:08:00 UTC
codegen make is failing on our new JDK 8 test environment.

Output:
https://gist.github.com/pjcollins/ec110861879eb8f9d292

Environment:
OSX Mavericks
XA master / 262472d2
Comment 1 Jonathan Pryor 2014-07-17 18:26:37 UTC
Here's the error:

> 				Tool /usr/bin/java execution started with arguments: -XX:-UseSplitVerifier -jar /Library/Frameworks/Xamarin.Android.framework/Versions/Current/lib/mandroid/jar2xml.jar --jar=/Users/xamarinqa/QABot/data/lanes/473/ff8212a0/source/monodroid/tests/codegen/Xamarin.Android.McwGen-Tests/bin/Debug/xamarin-test.jar --ref=/Users/xamarinqa/Library/Developer/Xamarin/android-sdk-macosx/platforms/android-8/android.jar --out=/Users/xamarinqa/QABot/data/lanes/473/ff8212a0/source/monodroid/tests/codegen/Xamarin.Android.McwGen-Tests/obj/Debug/api.xml --ref=/Users/xamarinqa/QABot/data/lanes/473/ff8212a0/source/monodroid/tests/codegen/Xamarin.Android.McwGen-Tests/bin/Debug/empty-1.jar --ref=/Users/xamarinqa/QABot/data/lanes/473/ff8212a0/source/monodroid/tests/codegen/Xamarin.Android.McwGen-Tests/bin/Debug/empty-2.jar 
> 				Java HotSpot(TM) 64-Bit Server VM warning: ignoring option UseSplitVerifier; support was removed in 8.0
> 				java.lang.IllegalArgumentException
> 					at org.objectweb.asm.ClassReader.<init>(ClassReader.java:167)
> 					at org.objectweb.asm.ClassReader.<init>(ClassReader.java:153)
> 					at org.objectweb.asm.ClassReader.<init>(ClassReader.java:458)
> 					at jar2xml.JavaArchive.getPackages(JavaArchive.java:81)
> 					at jar2xml.JavaArchive.getPackages(JavaArchive.java:64)
> 					at jar2xml.Start.main(Start.java:126)
> JARTOXML:  warning J2X9001: Couldn't load class com/xamarin/android/Bxc4288 : java.lang.IllegalArgumentException
Comment 3 Atsushi Eno 2014-07-30 06:02:12 UTC
The jar2xml issue is gone by upgrading asm.