Bug 21306 - xsp4 is stopped when rebuilding
Summary: xsp4 is stopped when rebuilding
Status: NEW
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: ASP.Net ()
Version: 5.1
Hardware: PC Windows
: --- normal
Target Milestone: master
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-07-14 11:21 UTC by pinggi
Modified: 2015-03-09 14:38 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 21306 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description pinggi 2014-07-14 11:21:28 UTC
1. Start a web app (press ctrl + F5)

	The web page is shown in the default web browser and info is written to the output:

	Adding applications '/:.'...
	Registering application:
	    Host:          any
	    Port:          any
	    Virtual path:  /
	    Physical path: C:\Web\Web\
	xsp4
	Listening on address: 127.0.0.1
	Root directory: C:\Web\Web
	Listening on port: 80 (non-secure)

2. Go back to Xamarin studio and Rebuild All (press F8)

	The project is rebuilt and xsp4 web server is still running (you can refresh the page in the browser as a proof)

3. Add a new line to the source code and Rebuild All (press F8)

	The following lines are added to the output:

	Change: C:\Web\Web\bin\Web.dll
	Change: C:\Web\Web\Bin\Web.dll

4. Web server is stopped

I expect here that it would be rebuilt without stopping the web server and I go back to the web browser and refresh the page to see the changes I have done to the code.

This works in Visual Studio like that but in Xamarin Studio I need to run the web app again, wait, close the old tab in the browser etc.

Could you let the web server running even the libraries are changed please?
Comment 1 pinggi 2014-07-14 11:49:11 UTC
Looks like issue of the XSP4 web server. When assemblies are moved to Bin folder or web.config is changed, the XSP4 is stopped (cmd.exe->mono.exe process are removed).