Bug 21151 - Cannot install extension for VS2013 if Visual Studio 2012 is also installed on PC
Summary: Cannot install extension for VS2013 if Visual Studio 2012 is also installed o...
Status: RESOLVED ANSWERED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Installer ()
Version: 3.1
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-07-07 12:22 UTC by Greg Ferreri
Modified: 2016-12-22 19:01 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Installer log (7.24 KB, text/plain)
2014-07-07 12:22 UTC, Greg Ferreri
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED ANSWERED

Description Greg Ferreri 2014-07-07 12:22:22 UTC
When Visual Studio 2012 and 2013 are both installed on the target machine, the Xamarin installer will not install the extension for Visual Studio 2013.

The installer wizard completes with the message "It appears that your system is already set up to use Xamarin in Visual Studio 2012!" 

Installer log attached.
Comment 1 Greg Ferreri 2014-07-07 12:22:52 UTC
Created attachment 7287 [details]
Installer log
Comment 2 Sunil Kumar 2014-07-25 11:48:42 UTC
We have tried to reproduce this issue but we are not able to reproduce. We are able to install the extension for Visual Studio 2013 on target machine, on which both VS 2012 and 2013 are installed.

Screencast: http://screencast.com/t/FKsDXiqUX4
Installer Log: https://gist.github.com/anonymous/79ea92851edff674f4b9

Please let us know if we have to perform any other steps to reproduce this issue?

Environment info:
Windows 8 Pro
VS 2010, 2012 and 2013
Latest installer of Xamarin which includes "Xamarin for Visual Studio 3.1.228".
Comment 3 Greg Ferreri 2014-07-25 13:46:02 UTC
Your installation log definitely looks different than mine. In my scenario, the Xamarin installer did not attempt to install the extension for Visual Studio 2013. Perhaps it occurs when VS 2012 has been installed with the extension, then VS 2013 is installed, and the Xamarin installer is run again.

My environment is Windows 7 Pro with VS 2012 and 2013.

I was able to get the extension installed by manually downloading the visual studio extension msi from 

http://download.xamarin.com/XamarinforVisualStudio/Windows/Xamarin.VisualStudio_Setup-3.1.228.0.msi
Comment 4 Jose Gallardo 2016-12-22 19:01:47 UTC
We've seen a similar issue recently, and it was related to Windows 7 not asking for elevation. Can you please try installing from an elevated command-prompt?

Thanks.