Bug 2107 - Stack trace when plugging in tablet
Summary: Stack trace when plugging in tablet
Status: RESOLVED DUPLICATE of bug 1048
Alias: None
Product: Android
Classification: Xamarin
Component: Tools and Addins ()
Version: 1.0
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-11-21 04:11 UTC by Philippe Girolami
Modified: 2011-11-21 11:50 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 1048

Description Philippe Girolami 2011-11-21 04:11:37 UTC
In Visual Studio 2010, using plugin version.
When I replug my tablet in the morning after leaving VS on all night, I often get a VS "Unhandled exception" window with the following information

Exception Type: System.FormatException
Exception Message: String was not recognized as a valid DateTime.
Exception Stack Trace:    at System.DateTimeParse.ParseExact(String s, String format, DateTimeFormatInfo dtfi, DateTimeStyles style)
   at Novell.MonoDroidVS.LogCatControl.GotData(Object sender, DataReceivedEventArgs e)
   at System.Diagnostics.Process.OutputReadNotifyUser(String data)
   at System.Diagnostics.AsyncStreamReader.FlushMessageQueue()
   at System.Diagnostics.AsyncStreamReader.GetLinesFromStringBuilder()
   at System.Diagnostics.AsyncStreamReader.ReadBuffer(IAsyncResult ar)
   at System.Runtime.Remoting.Messaging.AsyncResult.SyncProcessMessage(IMessage msg)
   at System.Runtime.Remoting.Messaging.StackBuilderSink.AsyncProcessMessage(IMessage msg, IMessageSink replySink)
   at System.Runtime.Remoting.Proxies.AgileAsyncWorkerItem.DoAsyncCall()
   at System.Runtime.Remoting.Proxies.AgileAsyncWorkerItem.ThreadPoolCallBack(Object o)
   at System.Threading.QueueUserWorkItemCallback.WaitCallback_Context(Object state)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean ignoreSyncCtx)
   at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem()
   at System.Threading.ThreadPoolWorkQueue.Dispatch()
   at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback()


-------------------------

Installed Extensions
	AnkhSVN - Subversion Support for Visual Studio
	State	=	Enabled
	Version	=	2.1.10129.17

	Process Template Editor
	State	=	Enabled
	Version	=	2.0

	WITDesigner
	State	=	Enabled
	Version	=	2.0.0.0

	MonoDroid for Visual Studio
	State	=	Enabled
	Version	=	1.0

	MonoTouch
	State	=	Enabled
	Version	=	1.0

	VSCommands 2010
	State	=	Enabled
	Version	=	3.7.3.6

	Quick Open File for Visual Studio 2010
	State	=	Enabled
	Version	=	1.2

	Productivity Power Tools
	State	=	Enabled
	Version	=	10.0.20626.18

	Project Linker
	State	=	Enabled
	Version	=	2.2.0.0



-------------------------

Environment Data
VisualStudio.Version	=	10.0
VisualStudio.Edition	=	Professional
VisualStudio.FullName	=	C:\Program Files\Microsoft Visual Studio 10.0\Common7\IDE\devenv.exe
VisualStudio.RegistryRoot	=	Software\Microsoft\VisualStudio\10.0
VisualStudio.LocaleId	=	1033
VisualStudio.DisplayMode	=	vsDisplayMDITabs
Time.UTC	=	21/11/2011 09:08:59
Time.Local	=	21/11/2011 10:08:59
OS.Architecture	=	x86
Environment.Version	=	4.0.30319.235
Environment.HasShutdownStarted	=	False
Environment.OSVersion.Platform	=	Win32NT
Environment.OSVersion	=	5.1.2600.196608
CurrentThread.Id	=	1
CurrentThread.Name	=	[null]
CurrentThread.ThreadState	=	Background
CurrentThread.IsBackground	=	True
CurrentThread.UICulture	=	English (United States)
CurrentThread.Culture	=	French (France)
Process.PagedMemorySizeMB	=	292,796875
Process.MaxWorkingSetMB	=	1,34765625
Process.NonpagedSystemMemorySizeMB	=	0,0411224365234375
Process.PagedSystemMemorySizeMB	=	0,878025054931641
Process.PrivateMemorySizeMB	=	292,796875
Process.VirtualMemorySizeMB	=	807,70703125
Process.WorkingSetMB	=	331,11328125
Process.UpTime	=	2.17:20:06.7868843
Comment 1 Philippe Girolami 2011-11-21 04:12:27 UTC
Forgot to mention that VS crashes & I have to restart it.
Intersetingly enough, I also have two "adb.exe" running in my process list.
Comment 2 Jonathan Pobst 2011-11-21 11:50:34 UTC
Fixed for 2.0.  Thanks for the report!

*** This bug has been marked as a duplicate of bug 1048 ***