Bug 21017 - ConnectCallback needs to call EndConnect
Summary: ConnectCallback needs to call EndConnect
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: General ()
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Martin Baulig
URL:
Depends on:
Blocks:
 
Reported: 2014-07-01 13:54 UTC by John Miller [MSFT]
Modified: 2014-08-25 12:24 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Sample project (3.74 KB, application/zip)
2014-07-01 13:54 UTC, John Miller [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description John Miller [MSFT] 2014-07-01 13:54:47 UTC
Created attachment 7250 [details]
Sample project

### Overview: 

    While trying to perform a socket connection from Xamarin.iOS using System.Net.Sockets.Socket.ConnectAsync, errors do not get propagated to the completion handler. The handler always reports SocketError.SocketSuccess.

### Steps to Reproduce: 

    1. Run the attached sample project.

### Actual Results: 

    SocketError is SocketError.SocketSuccess

### Expected Results: 

    SocketError.ConnectRefused

### Build Date & Platform: 

    Mono 3.6.0
    XI 7.2.6.7

### Additional Information: 

    Pull request here: https://github.com/mono/mono/pull/1142
Comment 1 narayanp 2014-08-05 10:20:17 UTC
I have checked this issue and when I run the attached project in XS on mac then it gives following exception : 

Exception : https://gist.github.com/Mohit-Kheterpal/b927e7d41896f6a34ab4

IDE Log : https://gist.github.com/Mohit-Kheterpal/9309c0f0d331c32fcb59

screencast : http://screencast.com/t/5nwbtxkG5yf

Please let me know how can I verify this issue and I am not sure in which build issue is fixed ?

I have checked it on following environment :

=== Xamarin Studio ===

Version 5.3 (build 412)
Installation UUID: 449f40dd-b3f1-4028-9a6b-cca0d1a2307d
Runtime:
	Mono 3.8.0 ((no/9ffca33)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 308000002

=== Apple Developer Tools ===

Xcode 5.1.1 (5085)
Build 5B1008

=== Xamarin.Mac ===

Version: 1.10.0.4 (Enterprise Edition)

=== Xamarin.Android ===

Version: 4.16.0 (Enterprise Edition)
Android SDK: /Users/360logicaxamarinmacmini/Desktop/android-sdk-macosx
	Supported Android versions:
		1.6    (API level 4)
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		3.2    (API level 13)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		4.5    (API level 21)
Java SDK: /usr
java version "1.7.0_65"
Java(TM) SE Runtime Environment (build 1.7.0_65-b17)
Java HotSpot(TM) 64-Bit Server VM (build 24.65-b04, mixed mode)

=== Xamarin.iOS ===

Version: 7.4.0.87 (Enterprise Edition)
Hash: 15e098c
Branch: 
Build date: 2014-08-04 08:20:20-0400

=== Build Information ===

Release ID: 503000412
Git revision: 77e042831804079a649ee83092ed36c7c10773a2
Build date: 2014-08-01 06:32:22-04
Xamarin addins: 57e379e6a9454a1c0d97aa3f770e7ae7cc16c522

=== Operating System ===

Mac OS X 10.8.4
Darwin 360Logicas-Mac-mini.local 12.4.0 Darwin Kernel Version 12.4.0
    Sun Mar 10 18:01:10 PDT 2013
    root:xnu-2050.24.6~1/RELEASE_X86_64 x86_64
Comment 2 Martin Baulig 2014-08-05 12:10:06 UTC
Ok, reopening.

The bug was RESOLVED / FIXED because the pull request was already merged, but maybe there's something else, I'll have a look.