Bug 20955 - Xamarin XAML Intellisense Broken / Missing Designer
Summary: Xamarin XAML Intellisense Broken / Missing Designer
Status: RESOLVED INVALID
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: General ()
Version: 3.1
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-06-27 15:07 UTC by Gutemberg
Modified: 2015-10-07 08:47 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description Gutemberg 2014-06-27 15:07:17 UTC
Hi!

I'm trying to use Xamarin on Visual Studio to design XAML for the UI of the 3 platforms supported but there is two problems:

1. The Intellisense isn't working. Seems that there is no schema(.xsd) configured on Visual Studio to support the XAML of Xamarin.
2. The visual Designer don't work. There is no way to see the XAML rendering on Visual Studio as it does for Windows Phone or even Android XML
Comment 1 Akhilesh kumar 2014-07-11 07:18:23 UTC
I have checked this issue with XVS 3.1.215 and observe that when we start typing the code in XAML file, auto completion does not appear and there is no way to see the xaml code rendering in designer view. 

Screencast : http://www.screencast.com/t/n0iBtwk00

VS 2013
XVS 3.1.215
Comment 2 CraigD 2014-08-25 19:14:11 UTC
The Visual Studio designer for WPF and Windows Phone/Silverlight XAML cannot render Xamarin.Forms XAML pages, the underlying control-set is completely different. This is not a bug, there is currently no "designer" support for Xamarin.Forms XAML.

The Visual Studio XML editor also does not provide intellisense for Xamarin.Forms XAML. This is not a bug, it is currently unsupported.

Feature requests such as these can be added/voted on at http://xamarin.uservoice.com/forums/258559-xamarin-forms-suggestions

If we add these features in future versions of Xamarin.Forms they will be announced via the release notes. Thanks for your feedback.
Comment 3 Mark 2015-01-06 12:17:19 UTC
Hi,

I am having this problem and was wondering if it is fixed in 3.8.150.0?
what status RESOLVED INVALID means?

Thank you
Mark
Comment 4 CraigD 2015-01-06 14:10:57 UTC
Mark,

'RESOLVED INVALID' basically means this has been closed.

It is not a bug: the XAML used by Xamarin.Forms is not the same as WPF, WindowsPhone/Silverlight and therefore you cannot use the Microsoft design tools to create Xamarin.Forms views. Many people have asked for a visual designer as a *feature request* - but it is not a bug.

You can get Intellisense working for Xamarin.Forms XAML on Visual Studio by installing this extension:
http://www.cazzulino.com/mobileessentials.html
Comment 5 Mark 2015-01-06 14:36:45 UTC
thank you Craig,
yes I do use mobileessentials and get intellisense in XAML but in code behind i have those annoying RED lines (but still compiles ok) so I thought somehow it was connected to this problem.
Comment 6 Mark 2015-01-06 15:48:45 UTC
thank you Craig,
yes I do use mobileessentials and get intellisense in XAML but in code behind i have those annoying RED lines (but still compiles ok) so I thought somehow it was connected to this problem.