Bug 20926 - GooglePlayServices component sample and others are failing to build
Summary: GooglePlayServices component sample and others are failing to build
Status: VERIFIED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: General ()
Version: 4.14.0
Hardware: PC Mac OS
: Highest blocker
Target Milestone: 4.14.0
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2014-06-26 19:10 UTC by Peter Collins
Modified: 2014-07-07 10:13 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
repro component sample (836.73 KB, application/zip)
2014-06-26 19:17 UTC, Peter Collins
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Peter Collins 2014-06-26 19:10:34 UTC
The following error has caused regressions in 12 component samples. These samples package without issue against monodroid 4.12.5.

Steps to reproduce:
1. Download and unzip attachment
2. xbuild /t:SignAndroidPackage googleplayservices-16.0/samples/GooglePlayServicesApp/GooglePlayServicesApp/GooglePlayServicesApp.csproj

UNEXPECTED TOP-LEVEL EXCEPTION:
java.lang.IllegalArgumentException: already added: Landroid/support/v4/print/PrintHelper$1;

Diagnostic Build output:
https://gist.github.com/pjcollins/9b9525e3291d300de77d

Environment:
OSX Mavericks
XA 4.14-series / b5c14449
Comment 1 Peter Collins 2014-06-26 19:17:07 UTC
Created attachment 7206 [details]
repro component sample
Comment 2 Peter Collins 2014-06-26 19:20:34 UTC
Disregard the link to the sample in comment 0, please download from the attachments section.
Comment 3 Jonathan Pryor 2014-07-01 16:00:09 UTC
Fixed in monodroid/424fdd1b?
Comment 4 Jonathan Pryor 2014-07-01 17:51:08 UTC
Fixed in monodroid-4.14-series/19d3da70.
Comment 5 Saurabh 2014-07-07 10:13:45 UTC
I have checked this issue with following builds

X.S 5.2 (Build 180)
Git revision: c27cfff0160e6f3d8ad82b57be030d6adf866743
X.Android 4.14.0-46

I have downloaded attached sample and build it using xbuild command. It builds successfully. This is the gist of Output: https://gist.github.com/saurabh360/bfaf4aa29b5dac62e030