Bug 20886 - Window Icon doesn't display in window manager
Summary: Window Icon doesn't display in window manager
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: Windows.Forms ()
Version: 3.2.x
Hardware: PC Linux
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-06-25 13:35 UTC by Stephen McConnel
Modified: 2014-10-09 16:12 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
The test program simply opens up a window that should should assign a nice icon that the windom manager can use. On Linux/Mono, the window manager doesn't display the assigned icon. (111.84 KB, application/zip)
2014-06-25 13:35 UTC, Stephen McConnel
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Stephen McConnel 2014-06-25 13:35:03 UTC
Created attachment 7182 [details]
The test program simply opens up a window that should should assign a nice icon that the windom manager can use.  On Linux/Mono, the window manager doesn't display the assigned icon.

The assigned Window Icon is not reflected in whatever display the window manager makes to represent the program.  For example, the Unity Launcher shows a default ? icon instead of the desired icon that the window wants to display.
I'm attaching a simple program that demonstrates the problem.  I hope to produce a pull request shortly that will fix it.

I've seen this behavior on versions of Mono from 2.10.9 to 3.4.0.
Comment 1 Stephen McConnel 2014-06-26 12:27:39 UTC
A pull request has been created as https://github.com/mono/mono/pull/1129.
Comment 2 Alexis Christoforides 2014-10-09 16:12:37 UTC
Pull request merged, thanks!