Bug 2088 - Various occurences of Stacktrace: and app freeze while downloading images
Summary: Various occurences of Stacktrace: and app freeze while downloading images
Status: RESOLVED NORESPONSE
Alias: None
Product: Android
Classification: Xamarin
Component: BCL Class Libraries ()
Version: 1.9.2
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-11-18 09:16 UTC by David Bakkom
Modified: 2013-12-05 18:35 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NORESPONSE

Description David Bakkom 2011-11-18 09:16:10 UTC
I have an app that repeatedly downloads images (100-200KB) from the web, and saves them to file on disk. Also, the user can scroll thru these images via the UI.

At unpredictable points during the download, the app will freeze, and on the ADB log will appear a 'Stacktrace:' from mono. Normally it is halting on the allocation of some sort of byte array or structure.

I have logged some stack traces on the Mono for Android Forum, under the name 'Stacktrace generated from System.IO.Stream.CopyTo with 1.9.2', with user name 'hssoftware'.

This is a show stopper bug for me, as I am trying to get an app into the Kindle Fire app store by mid-December.

I appreciate any help you can provide on this problem.
Comment 1 Atsushi Eno 2012-09-24 05:56:11 UTC
This does not tell a lot and without reproducible so I can only guess, but it might be a duplicate of bug #7002 or #7025.
Comment 2 Miguel de Icaza [MSFT] 2013-05-13 15:21:18 UTC
Could you please provide a reproducible test case?
Comment 3 PJ 2013-11-19 17:05:31 UTC
This bug has been in the NEEDINFO state with no changes for the last 90 days. Can we put this back into the NEW or CONFIRMED state, or are we still awaiting response?

If there is no change in the status of this bug over the next two weeks, this bug will be marked as NORESPONSE.
Comment 4 PJ 2013-12-05 18:35:57 UTC
This bug has not been changed from the NEEDINFO state since my previous comment, marking as RESOLVED NORESPONSE.

Please feel free to REOPEN this bug at any time if you are still experiencing the issue. Please add the requested information and set the bug back to the NEW (or CONFIRMED) state.