Bug 20858 - Application aborts on start
Summary: Application aborts on start
Status: RESOLVED DUPLICATE of bug 20747
Alias: None
Product: iOS
Classification: Xamarin
Component: XI runtime ()
Version: 7.9.0.x
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-06-24 17:40 UTC by Paul Johnson
Modified: 2014-06-24 18:51 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 20747

Description Paul Johnson 2014-06-24 17:40:24 UTC
Using Xcode 6 beta 2 with the latest Xam.iOS on the alpha channel.

When I build my app, it deploys fine to the simulator, but on a real device I'm getting this throwback

Incident Identifier: 3C0888E9-80F4-4D1D-A167-3A78398F3D02
CrashReporter Key:   6d6ed4c6c56078f06409a472e798a404ab868c83
Hardware Model:      iPhone3,1
Process:             ftrack2ios [4609]
Path:                /var/mobile/Applications/740F2219-7B75-4EF4-A00C-C07199343C35/ftrack2farmappscomau.app/ftrack2ios
Identifier:          ftrack2ios
Version:             1.563 (2.5)
Code Type:           ARM (Native)
Parent Process:      launchd [1]

Date/Time:           2014-06-24 22:35:00.567 +0100
OS Version:          iOS 7.1.1 (11D201)
Report Version:      104

Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000001, 0x00000000e7ffdefe
Triggered by Thread:  0

Dyld Error Message:
  Symbol not found: _OBJC_CLASS_$_NSHTTPCookie
  Referenced from: /var/mobile/Applications/740F2219-7B75-4EF4-A00C-C07199343C35/ftrack2farmappscomau.app/ftrack2ios
  Expected in: /System/Library/Frameworks/CFNetwork.framework/CFNetwork
 in /var/mobile/Applications/740F2219-7B75-4EF4-A00C-C07199343C35/ftrack2farmappscomau.app/ftrack2ios
  Dyld Version: 324.1

This didn't happen prior to moving to Xcode 6 beta 2. If I revert to Xcode 5 (and drop down the version of Xam.iOS), the build seems to work on the device.
Comment 1 Rolf Bjarne Kvinge [MSFT] 2014-06-24 17:46:33 UTC
This will be fixed in the next Xamarin.iOS 8 alpha.

*** This bug has been marked as a duplicate of bug 20747 ***
Comment 2 Paul Johnson 2014-06-24 18:49:47 UTC
Thanks - any rough ETA on this?
Comment 3 Rolf Bjarne Kvinge [MSFT] 2014-06-24 18:51:44 UTC
Within a couple of weeks I believe, but it can sway a lot in either direction.