Bug 2081 - Mouse interaction with code document is inaccurate
Summary: Mouse interaction with code document is inaccurate
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 2.8.2
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2011-11-17 14:55 UTC by Neal
Modified: 2012-04-30 05:28 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Neal 2011-11-17 14:55:45 UTC
Hello,

I've noticed this since starting with MonoTouch and I'm sure many people experience it but simply don't report it.  It works, it gets the job done, but I figured I'll report this issue to hopefully someday get it resolve.

The problem is that when I go to select code by placing the mouse over the area I want to start selecting, I then click and drag to highlight the text.  The problem often is that the point in which the mouse down actually occurs is not where I actually click.  For example, if the word XamarinRocks was in code and I place my cursor to the right of the last letter which is "s" but not actually click yet, so my cursor is placed and then I click and drag left, the start highlight would typically be around the c in Rocks, i.e. a few letters in the direction of the selection.  The same can apply when stopping the click/highlight, it may not go all the way, etc.

There seems to be a lag or fidelity issue so that click and interaction with the code document is just not accurate. I'd like to see this improved so I don't have to struggle with this all the time or resort to using the keyboard to SHIFT + Left/Right arrow to select after the cursor is placed.

FYI
Comment 1 Mike Krüger 2012-04-20 03:18:38 UTC
I don't see the problem - a screencast may be helpful.
Comment 2 Mike Krüger 2012-04-30 05:28:49 UTC
I would like to get some feedback about this - I can't see any wrong selection behaviour - a screen cast is better in such cases.