Bug 20790 - "Unpair" and "Pair" buttons not available in Xamarin.iOS Build Host without internet connection
Summary: "Unpair" and "Pair" buttons not available in Xamarin.iOS Build Host without i...
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 3.1
Hardware: PC Mac OS
: --- minor
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-06-21 16:34 UTC by Brendan Zagaeski (Xamarin Team, assistant)
Modified: 2015-09-28 14:21 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Screenshot of the issue (44.36 KB, image/png)
2014-06-21 16:34 UTC, Brendan Zagaeski (Xamarin Team, assistant)
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Brendan Zagaeski (Xamarin Team, assistant) 2014-06-21 16:34:40 UTC
Created attachment 7145 [details]
Screenshot of the issue

The "Unpair" and "Pair" buttons are not available in the Xamarin.iOS Build Host app when the build host has no internet connection.

This is only a minor problem, but it means that if the user accidentally deletes the pairing data from the Windows side, doesn't have a backup copy of the PIN, and doesn't have an internet connection, then re-pairing via the GUI will not be possible.


## Steps to reproduce

1. Disconnect the Mac build host from the internet.

2. Quit and re-launch "Xamarin.iOS Build Host".


## Result

The Xamarin.iOS Build Host app shows "Refreshing Xamarin.iOS licenses", a spinner animation, and a greyed-out "Pair" button.

(Screenshot attached)


In this state, the build host can still be used to build and deploy iOS apps, so the only problem is if the user needs to re-pair.
Comment 1 Enzo Heredia 2015-09-28 14:20:53 UTC
this is no longer valid with XMA implementation. Closing.