Bug 20789 - In mtbservergui.log, change "Activation error" to "Activation info" where appropriate
Summary: In mtbservergui.log, change "Activation error" to "Activation info" where app...
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 3.1
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-06-21 14:59 UTC by Brendan Zagaeski (Xamarin Team, assistant)
Modified: 2015-09-29 16:38 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Brendan Zagaeski (Xamarin Team, assistant) 2014-06-21 14:59:33 UTC
Currently the `mtbservergui.log` file contains some messages that are marked as "Activation error", but are just part of the normal license refresh process:

> [21-Jun-2014 14:34:10] Activation error: Initial entitlements: iOS Business 2015-06-13 08:22:43Z
> [21-Jun-2014 14:34:10] Activation error: Running license sync for iOS
> [21-Jun-2014 14:34:10] Normal: Starting RefreshStatus : full : True showSpinner : True
> [21-Jun-2014 14:34:10] Normal: RefreshStatus Completed.
> [21-Jun-2014 14:34:11] Activation error: Building request for POST to https://activation.xamarin.com/api/studio.ashx?token=52fc00cdc88d4a299709fbdcd7b223d8&guid=8d1ac05710ba4d9481f69450e14cc450&product=MT, with content length 652 and content type text/plain, without cookie.
> [21-Jun-2014 14:34:11] Activation error: Built request for POST to https://activation.xamarin.com/api/studio.ashx?token=52fc00cdc88d4a299709fbdcd7b223d8&guid=8d1ac05710ba4d9481f69450e14cc450&product=MT, request ID: -1216830080.
> [21-Jun-2014 14:34:11] Activation error: Executing request -1216830080.
> [21-Jun-2014 14:34:11] Activation error: Wrote request stream for request -1216830080.
> [21-Jun-2014 14:34:12] Activation error: Got response -2094973440 for request -2094973440.
> [21-Jun-2014 14:34:12] Activation error: Reading response -2094973440.
> [21-Jun-2014 14:34:12] Activation error: Read response stream for response -2094973440.
> [21-Jun-2014 14:34:12] Activation error: Updated license: iOS Business 6/13/2015 8:22:43 AM


To reduce confusion, perhaps these "errors" could be renamed to "Activation info" or something similar.


Thanks!


## Version information
Xamarin.iOS 7.2.6.3
Comment 2 Jatin 2014-09-09 09:58:30 UTC
Hi,

I have successfully able to reproduce this issue at my end. Below are the steps to reproduce this issue:

1. Install the latest build on mac (XS 5.3 (Build 441) + XI 7.4.0.108 + XA 4.16.0-16) as well as on windows (XS 5.3 (Build 441) + XVS 3.5.57)
2. Make a connection through build Host (Pairing and all)
3. Now On windows machine Activate the iOS license via VS
4. On the Mac machine navigate to the path "/Users/<machine_Name>/Library/Logs/Xamarin/MonoTouchVS"
5. Open the log file: "mtbservergui.log"
6. Observe that the file contains some messages that are marked as "Activation error", but those are just the part of the normal license refresh process.

Expected result as per the bug reported: The text "Activation error" should be replaced with "Activation info" as these are just the license refresh process and not any kind of error logs. Moreover, it will avoid confusion.

Environment information:
=== Xamarin Studio ===

Version 5.3 (build 441)
Installation UUID: 45555ffd-f3f0-4f29-9543-e369d711ab7d
Runtime:
	Mono 3.8.0 ((no/0806328)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 308000011

=== Apple Developer Tools ===

Xcode 5.1 (5084)
Build 5B130a

=== Xamarin.Android ===

Version: 4.16.0 (Trial Edition)
Android SDK: /Users/xamarin77/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1    (API level 7)
		2.2    (API level 8)
		2.3    (API level 10)
		3.1    (API level 12)
		3.2    (API level 13)
		4.0    (API level 14)
		4.0.3  (API level 15)
		4.1    (API level 16)
		4.2    (API level 17)
		4.3    (API level 18)
		4.4    (API level 19)
		4.4.87 (API level 20)
		4.5    (API level 21)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

=== Xamarin.iOS ===

Version: 7.4.0.108 (Business Edition)
Hash: 77efa3f
Branch: 
Build date: 2014-08-26 07:59:55-0400

=== Xamarin.Mac ===

Version:

=== Build Information ===

Release ID: 503000441
Git revision: befb6aa1176d37a5f678f4274f340a0159091b7a
Build date: 2014-09-08 17:57:02-04
Xamarin addins: 6dc7c388e31fdfc8014689839d37de0d4622435c

=== Operating System ===

Mac OS X 10.9.4
Darwin Xamarin77s-Mac-mini.local 13.3.0 Darwin Kernel Version 13.3.0
    Tue Jun  3 21:27:35 PDT 2014
    root:xnu-2422.110.17~1/RELEASE_X86_64 x86_64
Comment 3 Joaquin Jares 2015-09-29 16:38:34 UTC
With XMA this may not be relevant anymore. Closing as fixed for retest.