Bug 20747 - Running iOS 8 app on iOS 7 phone causes crash
Summary: Running iOS 8 app on iOS 7 phone causes crash
Status: RESOLVED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Xamarin.iOS.dll ()
Version: master
Hardware: PC Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
: 20858 ()
Depends on:
Blocks:
 
Reported: 2014-06-20 05:18 UTC by James Clancey
Modified: 2014-06-24 17:46 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description James Clancey 2014-06-20 05:18:46 UTC
I get the following crash with gMusic on an iOS 7 device.  It works on iOs 8 devices.

Dyld Error Message:
  Symbol not found: _OBJC_CLASS_$_NSHTTPURLResponse
  Referenced from: /var/mobile/Applications/CEAD4406-6FA0-4791-A598-26B1AF8FDA00/gMusic.app/gMusic
  Expected in: /System/Library/Frameworks/CFNetwork.framework/CFNetwork
 in /var/mobile/Applications/CEAD4406-6FA0-4791-A598-26B1AF8FDA00/gMusic.app/gMusic
  Dyld Version: 324.1

This happens on the simulator or device.
Comment 1 Ram Chandra 2014-06-20 08:02:04 UTC
Could you please provide "sample application" or "test steps" to reproduce this issue ? So that we can reproduce this issue at our end.
Comment 2 Rolf Bjarne Kvinge [MSFT] 2014-06-20 11:00:42 UTC
Fixed by Sebastien (see https://bugzilla.xamarin.com/show_bug.cgi?id=20739#c3).
Comment 3 Rolf Bjarne Kvinge [MSFT] 2014-06-24 17:46:33 UTC
*** Bug 20858 has been marked as a duplicate of this bug. ***