Bug 20732 - Cmd-A does not work in Properties fields to select all.
Summary: Cmd-A does not work in Properties fields to select all.
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS Designer ()
Version: 5.0.1
Hardware: Macintosh Mac OS
: High enhancement
Target Milestone: master
Assignee: Cody Russell
URL:
Depends on:
Blocks:
 
Reported: 2014-06-19 15:22 UTC by Jon Goldberger [MSFT]
Modified: 2015-01-22 00:14 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Jon Goldberger [MSFT] 2014-06-19 15:22:49 UTC
Enable Cmd-A to select all text of a selected property field.
Comment 1 Cody Russell 2015-01-13 14:21:03 UTC
This may or may not be related to bug #25987
Comment 2 Alan McGovern 2015-01-13 15:18:05 UTC

*** This bug has been marked as a duplicate of bug 13100 ***
Comment 3 Cody Russell 2015-01-14 16:21:57 UTC
Okay, weird stuff going on. I talked to Jon yesterday and he verified that he was unable to type any Cmd keys, for example Cmd-A, Cmd-C, Cmd-X, Cmd-Z, Cmd-Q.  Hence Alan reopened #13100.

testnsview confirmed that none of these worked.

So I've committed patches that solve this for testnsview, and when I test in Xamarin Studio I can confirm that I can now use Cmd-Q, Cmd-C, and Cmd-X in the property editor.  But what's weird is that Cmd-A still does not work there.  It works in the plain gtk test program testnsview.

So, I'm reopening this one as I close #13100.

(also, Cmd-Z has never worked before so that's unrelated. I have another patch that fixes Cmd-Z).
Comment 4 Cody Russell 2015-01-22 00:14:23 UTC
This is fixed by the following two commits:

bockbuild 2ef2dbdc7644a941d3665357bb760047dc05ff1d
monodevelop edaf3fc350485421d05c5458f7d1130ddf1a39f8