Bug 20691 - VS2010 is unresponsive when building
Summary: VS2010 is unresponsive when building
Status: RESOLVED INVALID
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: 3.0
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-06-18 15:48 UTC by John Miller [MSFT]
Modified: 2015-09-28 12:46 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description John Miller [MSFT] 2014-06-18 15:48:53 UTC
## Overview: 

    Visual Studio 2010 hangs and is unresponsive when the provided sample project is built. This same project can be built in VS2013 and it does not hang or cause VS to become unresponsive. It also seems to take much longer to build in VS2010 (~30 seconds) compared to VS2013 (~8 seconds).

## Steps to Reproduce: 

    1. Open the Test Case project (download in private comment) in VS 2010.

## Actual Results: 

    While building, VS2010 becomes unresponsive and appears to hang.

## Expected Results: 

    The same experience as VS2013 (responsive during build time).

## Build Date & Platform: 

    VS2010 
    Xamarin 3.0
    Windows 7

## Additional Information: 

    Confirmed by the customer on 2 different computers.
    Confirmed by support on Win 7 and VS 2010.
Comment 2 Udham Singh 2014-06-19 07:37:51 UTC
I have checked this issue with test case provided in comment 1 and noticed that when we built this application in VS 2010, VS 2010 becomes unresponsive and also noticed that some times it shows message "Not Responding".

Note : I am getting this issue intermittently. I got this issue 1 time out of 10.

Screencast : http://screencast.com/t/d02FVJ0dnp3v

Environment info :

Windows 7
Visual Studio 2010
Xamarin   3.0.54.0
Comment 3 Enzo Heredia 2015-09-28 12:46:33 UTC
VS2010 no longer supported. Closing.