Bug 2063 - Go to declaration does not always work correctly
Summary: Go to declaration does not always work correctly
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 2.8 Alpha 2
Hardware: PC Mac OS
: --- minor
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2011-11-16 15:43 UTC by Alan McGovern
Modified: 2011-12-09 08:03 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Alan McGovern 2011-11-16 15:43:26 UTC
Go to declaration does not always work correctly.It seems, that if file that contains needed declaration has at the beggining collapsed comments, then "Go to declaration" works wrong for the first time.If I use this feature again, then I go to the correct place.

MonoDevelop: 2.8.2
Runtime: Mono 2.10.6 (tarball Fri Sep 16 00:13:06 EDT 2011)
Operating System: Mac OSX (Unix 10.8.0.0)
Distributor: Xamarin
Comment 2 Mike Krüger 2011-12-09 08:03:03 UTC
Should work in new resolver branch.