Bug 20622 - Crash on alternate propertie's tabs between Layout and Widget
Summary: Crash on alternate propertie's tabs between Layout and Widget
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS Designer ()
Version: 3.1
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-06-16 12:09 UTC by Willian Correa
Modified: 2014-09-10 10:21 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Willian Correa 2014-06-16 12:09:37 UTC
This problem occurs in VS2012, VS2013 and Xamarin Studio


Open a storyboard with some screens inside. Selects a UI Element inside on one of these screens and make a simple change between Widget and Layout tabs on properties view.

This simple action make a crash with generic error in VS2012/13 and Xamarin Studio.
Comment 1 Mohit Kheterpal 2014-06-16 14:25:28 UTC
I have tried to reproduce this issue but I am unable to reproduce it as shown in screencast :http://screencast.com/t/2ZLQyf8WSc

Please have a look.

Could you please provide error log and IDE log via \AppData\Local\Xamarin\Log\11.0 or 12.0
Comment 2 Alan McGovern 2014-09-10 10:21:55 UTC
We fixed one or two causes of this recently, but they only occurred when Xcode6 was used. If you can trigger this problem again, can you share the storyboard which makes it happen?