Bug 20584 - Labels inside of a Grid are not WordWrapped
Summary: Labels inside of a Grid are not WordWrapped
Status: VERIFIED FIXED
Alias: None
Product: Forms
Classification: Xamarin
Component: Forms ()
Version: 1.0.6188
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-06-13 12:38 UTC by John Miller [MSFT]
Modified: 2015-02-10 10:07 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
TestCase (2.69 MB, application/zip)
2014-06-13 12:38 UTC, John Miller [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description John Miller [MSFT] 2014-06-13 12:38:02 UTC
Created attachment 7068 [details]
TestCase

## Overview: 

    Labels added to a Grid row/column are not word wrapped. 

## Steps to Reproduce: 

    1. Run the attached TestCase on ios/android. 

## Actual Results: 

    The text is not word wrapped.

## Expected Results: 

    Should be able to see Start and End in the string, but it runs off the screen instead.

## Build Date & Platform: 

    Forms 1.1.0.6201

## Additional Information: 

    Reported here: http://forums.xamarin.com/discussion/comment/58319#Comment_58319
Comment 1 Udham Singh 2014-08-08 10:00:41 UTC
I have checked this issue with the help of steps mentioned in bug description and getting same behavior.

Screencast : http://screencast.com/t/75dGcE08

Environment Info : 

=== Xamarin Studio ===

Version 5.2 (build 386)
Installation UUID: 011d70a5-dede-428b-ab04-ef451c2e539d
Runtime:
	Mono 3.6.0 ((no/f540f8a)
	GTK+ 2.24.23 (Raleigh theme)

	Package version: 306000039

=== Xamarin.Android ===

Version: 4.14.0 (Enterprise Edition)
Android SDK: /Users/MM/Desktop/android-sdk-macosx
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		3.2   (API level 13)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
		4.3   (API level 18)
		4.4   (API level 19)
Java SDK: /usr
java version "1.6.0_65"
Java(TM) SE Runtime Environment (build 1.6.0_65-b14-462-11M4609)
Java HotSpot(TM) 64-Bit Server VM (build 20.65-b04-462, mixed mode)

=== Apple Developer Tools ===

Xcode 5.1 (5084)
Build 5B130a

=== Xamarin.iOS ===

Version: 7.2.6.28 (Enterprise Edition)
Hash: 606f31a
Branch: 
Build date: 2014-08-01 15:27:48-0400

=== Xamarin.Mac ===

Version: 1.10.0.4 (Enterprise Edition)

=== Build Information ===

Release ID: 502000386
Git revision: e6a54dee5376e6e7a2d9982695b060fddc09e65d
Build date: 2014-08-04 14:03:28-04
Xamarin addins: 2b5a5c26ac2ee74c6e91a8d24ef44d0ca9cb74d0

=== Operating System ===

Mac OS X 10.9.2
Darwin MacMini.local 13.1.0 Darwin Kernel Version 13.1.0
    Thu Jan 16 19:40:37 PST 2014
    root:xnu-2422.90.20~2/RELEASE_X86_64 x86_64
Comment 2 Eric Maupin 2015-01-19 00:47:52 UTC
This should be fixed in a previous release.
Comment 3 Udham Singh 2015-02-10 10:07:36 UTC
I have checked this issue with Xamarin.Forms Version 1.3.4.6325-pre1 and observed that now this is working fine. Hence I am closing this issue.

Please refer the screencast : http://www.screencast.com/t/Ht7XuDiup9

Environment Info :

Xamarin.Forms : 1.3.4.6325-pre1

Mac OS X 10.9.5
Xamarin Studio 5.7.1 (build 17)
Mono 3.12.0 ((detached/a813491)
GTK+ 2.24.23 (Raleigh theme)
Xcode 6.2 (6770)
Xamarin.iOS 8.6.1.24 (Business Edition)
Xamarin.Android 4.20.0.28 (Business Edition)