Bug 20581 - RTE Tooltip appears mostly offscreen
Summary: RTE Tooltip appears mostly offscreen
Status: RESOLVED DUPLICATE of bug 13847
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger ()
Version: 5.0
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: master
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2014-06-13 09:48 UTC by David Ortinau [MSFT]
Modified: 2015-01-07 01:05 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
tip offscreen (63.58 KB, image/png)
2014-06-13 09:48 UTC, David Ortinau [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 13847

Description David Ortinau [MSFT] 2014-06-13 09:48:41 UTC
Created attachment 7065 [details]
tip offscreen

Screenshot attached kinda says it all.

Retina MBP running at retina resolution. When I hit an error and the code line is near right edge of the document viewport, the tooltip appears mostly offscreen (though within the XS chrome).

I expect the tip would appear onscreen under or above the line, not at the end when there is no room for it.

Running Yosemite 10.10, though I've seen this happen on 10.9 before in the past.
Comment 1 Tajinder Singh 2014-06-17 04:37:17 UTC
I tried this issue and I am able to reproduce this issue.

Steps to reproduce:

1. Create a "console project" on XS
2. Throw an exception from the "Main()" method.
 Ex : throw new Exception();
3. It shows an exception message (as expected)
4. Increase the size of any window on right side of XS ( toolbox/ Property/Document outline)
5. The tooltip appears offscreen. 

When I increase the size of "property view" which is docked on the right side of XS. The exception tooltip appears goes to the behind the "property view". 

Screencast: http://www.screencast.com/t/GzqeeHSeUH

Environment Info:

Mac OS X 10.9.2
Xamarin Studio: 5.0.1 (build 3)

=== Build Information ===

Release ID: 500010003
Git revision: f94ee866936d25105704eb63728ad5a981eda0a4
Build date: 2014-06-04 12:19:12-04
Xamarin addins: 1a6044e8321ea07e03a56b5381951686c82fed8b
Comment 2 Jeffrey Stedfast 2014-07-18 15:25:03 UTC
Tajinder: you are not reproducing the issue, you are just displaying other windows on top of the editor window.
Comment 3 Jeffrey Stedfast 2014-07-18 15:35:57 UTC
Looks like the TextEditor decides where to display this widget...
Comment 4 Mike Krüger 2014-07-19 00:45:31 UTC
That window can decide itself where it's displayed.

I suggest that when showing that window a scroll event should occur when that happens.
Comment 6 David Karlaš 2015-01-07 01:05:04 UTC
This was already fixed as another bug, but is not yet in Alpha channel

*** This bug has been marked as a duplicate of bug 13847 ***