Bug 20309 - Rendering delay with larger storyboard.
Summary: Rendering delay with larger storyboard.
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 3.0
Hardware: PC Windows
: Highest major
Target Milestone: 4.0.0 (C6)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-06-03 14:17 UTC by Jon Goldberger [MSFT]
Modified: 2015-05-27 08:33 UTC (History)
11 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Comment 1 Jon Goldberger [MSFT] 2014-06-03 14:20:17 UTC
Using the attached (private) storyboard file, I am experiencing about a 2 second delay between resizing a control, like a table view, and seeing the change rendered in the iOS Designer. 

My environment: 
Build host running on Mac OS X Mavericks
Windows VS 2013 Update 2 running on Windows 8.1 on a Parallels VM. 
Using Bridged network (No NAT)
Comment 2 Prashant manu 2014-06-05 08:33:15 UTC
Checked, with the attached storyboard file we observed Rendering delay.
Screencast: http://screencast.com/t/w9c76QhrtK

Environment Info:
All VS
Xamarin  3.0.54.0 (d3cf238e3845e930e312b6ec9b4c6c5437c33067)
Xam.iOS 7.2.3.39
Comment 6 Alan McGovern 2014-09-11 07:27:50 UTC
Moving this off the ios designer as the latency is not coming from designer code. It's either OS level or caused by the infrastructure we go through within the ios addin itself.
Comment 7 Daniel Cazzulino 2014-09-23 11:40:54 UTC
Alan, from your own messages, it looks like you can only attribute to MTBS about 246ms. The observed delay is 2' or more. So I fail to see how this can possibly be a problem of the MTBS stack. 

If the rendering took 246ms, I doubt anyone would be complaining.

Hence, moving off of the VS product.
Comment 13 Alan McGovern 2015-03-16 11:32:29 UTC
I believe this was fixed?
Comment 16 Alan McGovern 2015-03-18 21:02:46 UTC
If i remember correctly, this bug was caused by VS constantly background invoking the pngcrush task which clogged up the connection which delayed the VS/mtbs commucations which the designer needed.

The 2/5 second delay you're seeing is likely bug #28044 which has already been fixed. Bumping to the latest md-addins will fix that in VS.

As the issue that caused this bug has been fixed, we can probably close this.
Comment 17 Danish Akhtar 2015-05-27 08:33:45 UTC
Today, I have checked this issue with XVS 3.11.585 now this is working fine, there is no Rendering delay with attached test file in VS.

Hence closing this issue.

Environment info:
VS 2013
X.iOS 8.10.1.64
XVS 3.11.585
Xcode 6.2