Bug 20156 - Cannot select a specific one of two identical Android physical devices for deployment.
Summary: Cannot select a specific one of two identical Android physical devices for de...
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: 1.12.x
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: vsx
URL:
Depends on:
Blocks:
 
Reported: 2014-05-29 13:54 UTC by Jon Goldberger [MSFT]
Modified: 2015-11-26 10:38 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
VS Xamarin Log folder (56.75 KB, application/zip)
2014-05-29 13:54 UTC, Jon Goldberger [MSFT]
Details
Image of device picker drop downs (29.17 KB, image/png)
2014-05-29 13:57 UTC, Jon Goldberger [MSFT]
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Comment 1 Jon Goldberger [MSFT] 2014-05-29 13:56:27 UTC
From case: 

Hello, I have a project where I need to debug 2 phones at once as they are
initiating P2P connections. When I tried the wifi direct sample in Xamarin
Studio, I was able to run 2 instances and select my device by ID, and as
such I could debug both phones at once over USB.

Now, in VS as you can see by the attached picture, both devices show as the
same name/type (they are both Nexus 5), but it is not able to differentiate
between them so either dropdown selection results in only 1 of the phones
being debugged. Changing the Android Device Logger to the other device did
not change the target, so there appears to be a bug with this where I am
unable to attach to the other device unless I first unplug the phone which
it keeps picking as the target. I wonder if the difference is invoking ADB
by name instead of by serial number/device number, that it's not able to
tell the difference between the 2 phones?
Comment 2 Jon Goldberger [MSFT] 2014-05-29 13:57:17 UTC
Created attachment 6912 [details]
Image of device picker drop downs
Comment 3 Jon Goldberger [MSFT] 2014-05-29 13:58:34 UTC
VS Relevant Information:

Microsoft Visual Studio Ultimate 2012
Version 11.0.60610.01 Update 3
Microsoft .NET Framework
Version 4.5.50709

Visual C# 2012 04940-004-0039002-02561
Microsoft Visual C# 2012

Xamarin for Visual Studio 1.12.278.0
(b3acb09afda91828e5bd48308ac8e7433d30f330)
Visual Studio extension to enable development for Xamarin.iOS and
Xamarin.Android

Xamarin.Android 4.12.3.3 (7f0e3d3cfb9b36570e8d7862a33d0310238c814d)
Visual Studio plugin to enable development for Xamarin.Android.

Xamarin.iOS 1.12.278.0 (b3acb09afda91828e5bd48308ac8e7433d30f330)
Visual Studio extension to enable development for Xamarin.iOS
Comment 4 Saurabh 2014-06-03 14:23:59 UTC
I have checked this issue with latest stable builds:

VS 2013 Update 2
Xamarin  3.0.54.0 (d3cf238e3845e930e312b6ec9b4c6c5437c33067)
Xamarin.Android   4.12.4.20 (b5dc5ce91305e19de51d71a1122c109719c4bc34)
Xamarin.iOS   3.0.54.0 (d3cf238e3845e930e312b6ec9b4c6c5437c33067)

I have attached two android device having same name. Here I am able to deploy application on one device. When I selects second device and try to deploy app on it, VS deploys the application on first device every time.

I have two devices having same name(http://www.screencast.com/t/26UsXJzn), application deploys successfully on first device. Now, tried to deploy the application on second device by selecting it. But VS deploy application every time on same device.

Screencast: http://www.screencast.com/t/m0CTWSvaDh
Comment 5 xamarin-release-manager 2015-10-21 11:45:59 UTC
Fixed in version 99.0.0.431 (master)

Author: Daniel Cazzulino
Commit: 682908e20a8d7ca1109537ea34f426a5140bda90 (xamarin/XamarinVS)
Comment 6 xamarin-release-manager 2015-11-26 10:38:40 UTC
Fixed in version 4.0.1.1 (cycle6)

Author: Daniel Cazzulino
Commit: 682908e20a8d7ca1109537ea34f426a5140bda90 (xamarin/XamarinVS)