Bug 20023 - Attribute constructions fails when dependency assembly is not loaded (blocks StyleCop)
Summary: Attribute constructions fails when dependency assembly is not loaded (blocks ...
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: Reflection ()
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Rodrigo Kumpera
URL:
Depends on:
Blocks:
 
Reported: 2014-05-24 04:13 UTC by Marek Safar
Modified: 2014-05-27 16:37 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
repro (2.26 MB, application/zip)
2014-05-24 04:14 UTC, Marek Safar
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Marek Safar 2014-05-24 04:13:12 UTC
.NET prints

r.exe
StyleCop.StyleCopAddInAttribute[]

Mono

Unhandled Exception:
System.TypeLoadException: Could not load type StyleCop.CSharp.CsParser, StyleCop.CSharp, Version=4.7.1000.0, Culture=neutral, PublicKeyToken=f904653c63bc2738 while decoding custom attribute
  at (wrapper managed-to-native) System.MonoCustomAttrs:GetCustomAttributesInternal (System.Reflection.ICustomAttributeProvider,System.Type,bool)
  at System.MonoCustomAttrs.GetCustomAttributesBase (ICustomAttributeProvider obj, System.Type attributeType, Boolean inheritedOnly) [0x00000] in <filename unknown>:0
  at System.MonoCustomAttrs.GetCustomAttributes (ICustomAttributeProvider obj, System.Type attributeType, Boolean inherit) [0x00000] in <filename unknown>:0
  at System.MonoType.GetCustomAttributes (System.Type attributeType, Boolean inherit) [0x00000] in <filename unknown>:0
  at A2.Main () [0x00000] in <filename unknown>:0
Comment 1 Marek Safar 2014-05-24 04:14:35 UTC
Created attachment 6873 [details]
repro
Comment 2 Rodrigo Kumpera 2014-05-27 11:46:24 UTC
working on it.
Comment 3 Rodrigo Kumpera 2014-05-27 16:37:10 UTC
Fixed on master.