Bug 19988 - Cannot load default config file when running on machine which does not have monomac installed
Summary: Cannot load default config file when running on machine which does not have m...
Status: RESOLVED DUPLICATE of bug 17225
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: Library (Xamarin.Mac.dll) ()
Version: 1.8.0
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: 2.0.x
Assignee: Chris Hamons
URL:
Depends on:
Blocks:
 
Reported: 2014-05-22 07:55 UTC by Radu
Modified: 2015-02-19 17:39 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 17225

Description Radu 2014-05-22 07:55:37 UTC
Making a reference to any predefined NSColor object (like NSColor.Black) seems to trigger loading of the fonts.conf file from from /Library/Frameworks/Mono.framework/Versions/Current/etc. When running the packaged product on a machine which doesn't have mono  installed (and of corse none of the Xamarin related software and platorms) the following line is spit on the console when it hits the first line referencing a predefined static color from NCColor:
Fontconfig error: Cannot load default config file

After the message, the process consumes a lot of cpu power for a while (even up to a minute on some machines) then the app continues to work normally and any further references to static predefined colors in NSColor don't block the running thread anymore.

To test this just make a very simple mac project and reference NSColor.Black (or whatever color you want) from a variable, then compile and try to run on a mac without mono on it (or temporarily move the fonts.conf file to some other location so you can actually debug this).
Comment 1 Radu 2014-05-22 08:24:34 UTC
Please excuse my haste in writing the description, I made a big mistake:
Any NSColor must be read as "Color" from the System.Drawing namespace
Comment 2 Johan H 2014-08-27 05:33:09 UTC
I beleive this bug is a duplicate of bug 17225 and bug 20210.
Comment 3 Chris Hamons 2015-02-19 17:39:46 UTC

*** This bug has been marked as a duplicate of bug 17225 ***