Bug 19839 - Could not load type Mono.Web.Util.RoleManagerSectionMapper
Summary: Could not load type Mono.Web.Util.RoleManagerSectionMapper
Status: RESOLVED FIXED
Alias: None
Product: Class Libraries
Classification: Mono
Component: System.Web ()
Version: master
Hardware: PC Linux
: --- normal
Target Milestone: Untriaged
Assignee: Marek Habersack
URL: http://lab.3dmarket.org/
Depends on:
Blocks:
 
Reported: 2014-05-15 18:17 UTC by Anton Maisak
Modified: 2014-05-20 04:14 UTC (History)
4 users (show)

Tags: Mono.Web.Util.RoleManagerSectionMapper
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Anton Maisak 2014-05-15 18:17:57 UTC
Mono JIT compiler version 3.4.1 (master/e0137c4 May 16 00:48:19 MSK 2014)
Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
        TLS:           __thread
        SIGSEGV:       altstack
        Notifications: epoll
        Architecture:  amd64
        Disabled:      none
        Misc:          softdebug
        LLVM:          supported, not enabled.
        GC:            sgen

I build Web Application MVC4 EF6 MySQL. (Before rebuilding mono all works fine)

OS ArchLinux, Ubuntu Server 12.04

Error WebSite http://lab.3dmarket.org/

Application Exception
System.TypeLoadException
Could not load type 'Mono.Web.Util.RoleManagerSectionMapper, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'.

Description: HTTP 500.Error processing request.
Details: Non-web exception. Exception origin (name of application or object): mscorlib.
Exception stack trace:
  at (wrapper managed-to-native) System.Type:internal_from_name (string,bool,bool)
  at System.Type.GetType (System.String typeName, Boolean throwOnError) [0x00000] in <filename unknown>:0 
  at Mono.Web.Util.SettingsMapping.get_MapperType () [0x00000] in <filename unknown>:0 
  at Mono.Web.Util.SettingsMapping.MapSection (System.Object input, System.Type type) [0x00000] in <filename unknown>:0 
  at Mono.Web.Util.SettingsMappingManager.MapSection (System.Object input, System.Type type) [0x00000] in <filename unknown>:0 
  at Mono.Web.Util.SettingsMappingManager.MapSection (System.Object input) [0x00000] in <filename unknown>:0 
  at System.Web.Configuration.WebConfigurationManager.GetSection (System.String sectionName, System.String path, System.Web.HttpContext context) [0x00000] in <filename unknown>:0 
  at System.Web.Configuration.WebConfigurationManager.GetSection (System.String sectionName) [0x00000] in <filename unknown>:0 
  at System.Web.Security.RoleManagerModule.Init (System.Web.HttpApplication app) [0x00000] in <filename unknown>:0 
  at System.Web.Configuration.HttpModulesSection.LoadModules (System.Web.HttpApplication app) [0x00000] in <filename unknown>:0 
  at System.Web.HttpApplication.InitOnce (Boolean full_init) [0x00000] in <filename unknown>:0 
Version Information: 3.4.1 (master/80b9d3a Пт. мая 16 00:37:47 MSK 2014); ASP.NET Version: 4.0.30319.17020
Powered by Mono
Comment 1 Artyom Antyipin 2014-05-20 04:03:01 UTC
I have the same issue, bit replacing "Mono.Web.Util.RoleManagerSectionMapper, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" with "Mono.Web.Util.RoleManagerSectionMapper, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" is /etc/mono/4.5/settings.map seems to fix it.
Comment 2 Marek Habersack 2014-05-20 04:14:35 UTC
Fixed in mono/master, commit 0c62f05785ca7c069d306791c021d5c09b87e9b8, thanks Artyom!