Bug 1956 - Mono supports VB.NET for .NET 4.0, but MonoDevelop doesn't know
Summary: Mono supports VB.NET for .NET 4.0, but MonoDevelop doesn't know
Status: NEW
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: VB.Net Binding ()
Version: unspecified
Hardware: PC Linux
: Low normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-11-09 04:44 UTC by Santiago M. Mola
Modified: 2011-11-15 15:29 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report for Bug 1956 on Developer Community or GitHub if you have new information to add and do not yet see a matching new report.

If the latest results still closely match this report, you can use the original description:

  • Export the original title and description: Developer Community HTML or GitHub Markdown
  • Copy the title and description into the new report. Adjust them to be up-to-date if needed.
  • Add your new information.

In special cases on GitHub you might also want the comments: GitHub Markdown with public comments

Related Links:
Status:
NEW

Description Santiago M. Mola 2011-11-09 04:44:41 UTC
Mono's VB.NET compiler supports .NET Framework 4.0. But MonoDevelop doesn't know about it:

<@mhutch> IIRC our VB.NET compiler doesn't support .NET 4
<@mhutch> I might be wrong though
<@mhutch> rolf_?
< rolf_> mhutch: it does
< rolf_> but I don't think the vb addin knows about it
< cw> should I file a bug about that?
< rolf_> cw: actually if the vb addin passes absolute paths to referenced assemblies it should just work
< rolf_> so yeah, please file a bug