Bug 1952 - Error "Failure [INSTALL_FAILED_OLDER_SDK]" occurs in deploying the application on Emulator at API 7.
Summary: Error "Failure [INSTALL_FAILED_OLDER_SDK]" occurs in deploying the applicatio...
Status: CLOSED DUPLICATE of bug 1929
Alias: None
Product: Android
Classification: Xamarin
Component: Mono runtime / AOT Compiler ()
Version: 1.9.2
Hardware: PC Windows
: --- major
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-11-09 03:19 UTC by narayanp
Modified: 2011-12-22 09:43 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED DUPLICATE of bug 1929

Description narayanp 2011-11-09 03:19:02 UTC
Step to Reproduce:

1. Launch MonoDevelop.
2. Click on "Open the existing Solution" link.
3. Browse the "ContactManager" application.
4. Build the application and select "Debug/Release" option under Active Configuration.
5. Click on Run from the top menu bar and select API 7 from select device
window.

Actual Result:
Error "Failure [INSTALL_FAILED_OLDER_SDK] " occurs in deploying the application
on Emulator in Debug/Release mode on API 7.

Error Details in Application Output tab:
D/AndroidRuntime(  259): Shutting down VM

E/AndroidRuntime(  259): Uncaught handler: thread main exiting due to uncaught exception

E/AndroidRuntime(  259): java.lang.RuntimeException: Unable to get provider mono.MonoRuntimeProvider: java.lang.RuntimeException: Unable to find application Mono.Android.DebugRuntime or Mono.Android.Platform.ApiLevel_8!

E/AndroidRuntime(  259): 	at android.app.ActivityThread.installProvider(ActivityThread.java:4270)

E/AndroidRuntime(  259): 	at android.app.ActivityThread.installContentProviders(ActivityThread.java:4042)

E/AndroidRuntime(  259): 	at android.app.ActivityThread.handleBindApplication(ActivityThread.java:4001)

E/AndroidRuntime(  259): 	at android.app.ActivityThread.access$2900(ActivityThread.java:119)

E/AndroidRuntime(  259): 	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1901)

E/AndroidRuntime(  259): 	at android.os.Handler.dispatchMessage(Handler.java:99)

E/AndroidRuntime(  259): 	at android.os.Looper.loop(Looper.java:123)

E/AndroidRuntime(  259): 	at android.app.ActivityThread.main(ActivityThread.java:4363)

E/AndroidRuntime(  259): 	at java.lang.reflect.Method.invokeNative(Native Method)

E/AndroidRuntime(  259): 	at java.lang.reflect.Method.invoke(Method.java:521)

E/AndroidRuntime(  259): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:860)

E/AndroidRuntime(  259): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:618)

E/AndroidRuntime(  259): 	at dalvik.system.NativeStart.main(Native Method)

E/AndroidRuntime(  259): Caused by: java.lang.RuntimeException: Unable to find application Mono.Android.DebugRuntime or Mono.Android.Platform.ApiLevel_8!

E/AndroidRuntime(  259): 	at mono.MonoRuntimeProvider.attachInfo(MonoRuntimeProvider.java:30)

E/AndroidRuntime(  259): 	at android.app.ActivityThread.installProvider(ActivityThread.java:4267)

E/AndroidRuntime(  259): 	... 12 more

E/AndroidRuntime(  259): Caused by: android.content.pm.PackageManager$NameNotFoundException: Mono.Android.Platform.ApiLevel_8

E/AndroidRuntime(  259): 	at android.app.ApplicationContext$ApplicationPackageManager.getApplicationInfo(ApplicationContext.java:1604)

E/AndroidRuntime(  259): 	at mono.MonoRuntimeProvider.attachInfo(MonoRuntimeProvider.java:22)

E/AndroidRuntime(  259): 	... 13 more

Expected Result:
Error should not occur in running the application and application should deploy
on the emulator successfully.

Environment:
MonoForAndroid 1.9.2
MonoDevelop 2.8.2

Note:- We have tried with Target framework :Mono for Android 2.1 also
Comment 1 narayanp 2011-11-09 03:27:31 UTC
Error "Error: Could not access the Package Manager.  Is the system running?" occurs when user run the application on API 14 in Debug/Release mode.
Comment 2 Jonathan Pryor 2011-11-09 20:26:12 UTC

*** This bug has been marked as a duplicate of bug 1929 ***
Comment 3 narayanp 2011-11-10 11:04:11 UTC
on MAC system:

API 14:(Debug/Release): Error: Could not access the Package Manager.  Is the system running?" occurs when we run the app.

API 7:(Debug/Release): "Failure [INSTALL_FAILED_OLDER_SDK" occurs when we run the app.
Comment 4 narayanp 2011-11-11 09:53:47 UTC
Error "Failure [INSTALL_FAILED_OLDER_SDK]" occurs in deploying the application on Emulator at API 7 in Debug/Release mode.

Environment:
MonoDevelop 3.0beta1(2.9)
MonoForAndroid 1.9.3
Comment 5 narayanp 2011-12-22 09:43:32 UTC
Now this issue has been fixed. New issue occurs when we run the app on API7.

Bug 2209 - Many samples layouts are not compatible with API Level 7
Hence closing this issue.