Bug 19433 - Crash in NSApplication.Init() when a generic subclass of a Mac class is present
Summary: Crash in NSApplication.Init() when a generic subclass of a Mac class is present
Status: VERIFIED FIXED
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: Library (Xamarin.Mac.dll) ()
Version: 1.8.0
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: 1.12.0
Assignee: Chris Hamons
URL:
Depends on:
Blocks:
 
Reported: 2014-04-30 16:14 UTC by Michael Teper
Modified: 2015-01-21 13:19 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Comment 1 Shruti 2014-07-16 04:44:11 UTC
Hi Michael

I have tried to reproduce this issue but unfortunately I am not able to reproduce it.

Could you please provide crash Log and IDE logs ?
(IDE Logs : Help > Open Log diectory)

Thanks!!
Comment 2 Michael Teper 2014-07-16 12:09:34 UTC
Shruti, I supplied both code and stack trace. This still happens, reliably. Could you tell me the steps you went through to reproduce the problem?
Comment 3 Miguel de Icaza [MSFT] 2014-12-03 14:39:34 UTC
Hello,

This should have been a warning, since our runtime did not support generics when subclassing NSObject.   

This should be addressed by the new joint runtime.

Chris, we should verify this and create a test case out of it.
Comment 4 Chris Hamons 2014-12-03 15:01:20 UTC
Seems reasonable. Will put in scope for 1.12.
Comment 5 Michael Teper 2014-12-03 16:31:38 UTC
So with joint runtime this will work?
Comment 6 Chris Hamons 2014-12-03 16:59:50 UTC
I believe it may. I'm having trouble producing a test case, as I'm having trouble finding the correct nuget packages. Can you point me to the correct libraries to reference to get ReactiveViewController.
Comment 7 Michael Teper 2014-12-03 18:41:18 UTC
http://www.nuget.org/Packages/reactiveui

Note that you will need to change the .csproj file to point to the MonoMac assembly in the NuGet package (see https://bugzilla.xamarin.com/show_bug.cgi?id=21338).
Comment 8 Chris Hamons 2014-12-04 11:07:56 UTC
That bug (21339) was what I was missing.

I can confirm that my example that crashes on Stable launches successfully on Alpha with the new runtime.

I'll talk to QA to get this added to our test suite so it doesn't break again.
Comment 9 Michael Teper 2014-12-04 19:15:08 UTC
Awesome, thank you!
Comment 10 Mohit Kheterpal 2015-01-21 13:19:43 UTC
I got following steps from https://trello.com/c/s1cr7PsI/114-add-test-for-bug-19433

Unzip https://www.dropbox.com/s/k6zwu1rgfbjqpkf/ReactTest.zip?dl=0 

- Open ReactTest.sln
- Update Packages to make sure we have recent React.
- Rebuild.
- Run
- On stable today, this will crash on launch. On alpha today (where the fix lives), this will launch successfully.
- Once 1.12 is releases to stable, it should work everywhere.

Using Xam.mac 1.12.0.4, after following above steps this issue is working fine. Hence, I am closing this issue by marking it as Verified.

Thanks