Bug 1943 - Format Selection feature does not work
Summary: Format Selection feature does not work
Status: CLOSED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: C# Binding ()
Version: 2.8.2
Hardware: PC Mac OS
: High normal
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2011-11-08 10:55 UTC by Chris Hardy [MSFT]
Modified: 2012-01-10 11:07 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED FIXED

Description Chris Hardy [MSFT] 2011-11-08 10:55:35 UTC
Format Selection feature does not work (But Format Document works).

Open a file with an empty first line.

Run "Format Document" and notice the first line gets correctly removed.

Undo this change and Select-All the document - run "Format Selection" and nothing changes.
Comment 2 Mike Krüger 2011-12-12 01:40:03 UTC
fixed.
Comment 3 Alexander Riman 2011-12-14 07:21:15 UTC
This bug is still not fixed in MD 2.8.5.
Comment 4 Mike Krüger 2011-12-14 09:49:54 UTC
2.8.5 was released/branched before the fix.
Comment 5 Saurabh 2011-12-29 06:43:03 UTC
We have verified this issue with MonoDevelop 2.8.5 and MonoTouch 5.0.4,This is still exist.even when first line is empty,Document format not removes first line.

Kindly reopen this bug.
Comment 6 Mike Krüger 2012-01-02 02:23:59 UTC
2.8.5 was branched >before< the fix ... that's why it isn't fixed there. We can't  restart the q&a process for every bugfix.
Comment 7 lindsey.driscoll 2012-01-10 11:06:32 UTC
This has been verified to work in MonoDevelop 2.8.6