Bug 19324 - Special characters in name
Summary: Special characters in name
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild ()
Version: 4.12.4
Hardware: PC Windows
: High normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2014-04-27 18:32 UTC by rubencm
Modified: 2017-06-27 00:17 UTC (History)
7 users (show)

Tags: bb
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description rubencm 2014-04-27 18:32:54 UTC
Error	6	Unexpected error - Please file a bug report at http://bugzilla.xamarin.com. Reason: System.UnauthorizedAccessException: Access to the path "C:\Users\Rub├®n" is denied.	Launcher
Comment 1 Nischal 2014-04-28 03:34:12 UTC
We have checked with 'Rub├®n' and observing same behavior if it is used in project name, Project Path or SDK Path.

Environment Info:
Xamarin Studio Version 5.0 (build 773)
Git revision: 4d32a9f5c376c79cf8e272c1cf981f6beeb4667f
Xamarin addins: 6ee7a0e6a2a63239a1927cd10992e26363400941
Xam.Android 4.12.4.5
Comment 2 Mohit Kheterpal 2014-04-29 14:45:12 UTC
Regression Status : Regression. This issue is working fine with XS 4.2.2 (build 2)
Comment 3 PJ 2014-04-29 15:48:19 UTC
This is an old bug in MSBuild targets according to Mhutch. That would make this an issue with the Android build, not XS. Mohit, are you sure you checked it with the same Android version installed? 

Either way, it seems like this has regressed recently from comment 2. I'm going to NEEDINFO for Mohit to investigate further.
Comment 4 Chris Hardy [MSFT] 2017-06-26 18:08:36 UTC
Thank you for taking the time to submit this report. After reviewing the description of this bug, we believe it no longer affects the current version of Xamarin.Android. If you are still experiencing the issue after updating your packages, please reopen this report with an attached reproduction.