Bug 19322 - Weird build error without any actual error
Summary: Weird build error without any actual error
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild ()
Version: 4.12.3
Hardware: PC Windows
: Normal normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2014-04-27 16:14 UTC by 999komi
Modified: 2017-06-27 00:17 UTC (History)
3 users (show)

Tags: bb
Is this bug a regression?: ---
Last known good build:


Attachments
Screen shot (83.75 KB, image/png)
2014-04-27 16:14 UTC, 999komi
Details
Project (101.13 KB, application/x-zip-compressed)
2014-04-27 16:20 UTC, 999komi
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description 999komi 2014-04-27 16:14:06 UTC
When nesting Android projects, I sometimes see a build "error" with blank text.  It doesn't actually stop the build from working, but it's still annoying.  

If you don't see it when opening the attached, try adding another level of nesting.  The chance that you will see it is high.  It appears to be related to the level of complication of the product.  Our production app shows it the vast majority of the time.
Comment 1 999komi 2014-04-27 16:14:56 UTC
Created attachment 6659 [details]
Screen shot
Comment 2 999komi 2014-04-27 16:20:41 UTC
Created attachment 6660 [details]
Project

This is the project that sometimes produces the error.
Comment 3 Sadik Ali 2014-04-28 06:03:54 UTC
I have checked this issue with attached project and follow the steps provided in bug description but I am unable to reproduce this issue.

Steps to reproduce
1. Open "attached project".
2. Build the attached project.
3. Add the portable class library and write the following code on Class1.cs
        public string S3
        {
            get
            {
                return "This PCL1";
            }
         }
4. Add the reference of portable class library to project two,one and Nest.
5. Get the values of property of portable class library  in  Activity1.cs
    Ex: string s3= r1.s3;
6. Build and debug the project.

I observed that when I build the attached project, I am not getting any error then I try to add new PCL to the attached project and create a new property "s3" to the PCL and add PCL reference to the project and again build the project but I am unable to reproduce this issue.
I have also tried to add few more PCL and class libraries but project is running successfully and  I am unable to reproduce this issue.

Screencast: http://www.screencast.com/t/x6Z7p9qp

Environment Info:

Operating System: Windows 7/ 8
Visual Studio 2013
Xamarin.Android : 4.12.3.3

Please let me know if I am missing anything?
Comment 4 Chris Hardy [MSFT] 2017-06-26 18:07:19 UTC
Because we have not received a reply to our request for more information we are closing this issue. If you are still encountering this issue, please reopen the ticket with the requested information. Thanks!