Bug 19321 - public override bool OpenUrl () not called in AppDelegate
Summary: public override bool OpenUrl () not called in AppDelegate
Status: RESOLVED INVALID
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: 7.1.0.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2014-04-27 08:05 UTC by services
Modified: 2014-05-08 13:08 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED INVALID

Description services 2014-04-27 08:05:03 UTC
Hi guys. I'm experiencing the same issue than here :
http://forums.xamarin.com/discussion/12306/openurl-not-being-called

OpenUrl is not called in  AppDelegate  (although my app is displayed when opening a file from the Mail app).

		public override bool OpenUrl (UIApplication application, NSUrl url, string sourceApplication, NSObject annotation)
		{
			// NOTE: Don't call the base implementation on a Model class
			// see http://docs.xamarin.com/guides/ios/application_fundamentals/delegates,_protocols,_and_events
			//throw new NotImplementedException ();
			//
			YApp.log ("***** >>>>>>>>>>>  OpenUrl  *** url" + url.ToString ());
			//
			return true;
		}




Xam Studio for iOS : 4.2.3 build 60 on latest XCode, Mavericks.

cheers,
Michel Szybist
Comment 1 Sebastien Pouliot 2014-04-27 10:48:09 UTC
Your version informations are incomplete (or wrong - it's unlikely you're using an old 7.1 alpha of Xamarin.iOS). Could you complete them ?

The easiest way to get exact version information is to use the "Xamarin Studio" menu, "About Xamarin Studio" item, "Show Details" button and copy/paste the version informations (you can use the "Copy Information" button).

Also please attach a self-contained (but as small as possible) test case showing the issue. Like it was mentioned on the forum this often happens when more than one AppDelegate is part of the application (and the wrong one is being used).
Comment 2 services 2014-05-08 12:56:11 UTC
Sorry for disturbing.

I took my code after one week, and it worked out of the box.
I had something unstable, maybe, somewhere.

You can file this.
Sorry, again.

Michel
Comment 3 Sebastien Pouliot 2014-05-08 13:08:37 UTC
No trouble :)