Bug 19319 - Compiler crashed with code: 1
Summary: Compiler crashed with code: 1
Status: RESOLVED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: MSBuild ()
Version: 4.12.3
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2014-04-27 02:51 UTC by renan jegouzo
Modified: 2015-12-15 08:19 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description renan jegouzo 2014-04-27 02:51:21 UTC
/Library/Frameworks/Mono.framework/Versions/3.2.6/lib/mono/4.0/Microsoft.CSharp.Targets: Error: Compiler crashed with code: 1. (AlibDroid)

http://pastebin.com/03WtiN5R
Comment 1 Jonathan Pryor 2014-04-28 14:47:54 UTC
One of two things is happening:

1. Your C# code is causing the mono C# compiler to crash -- in which case we'll need your C# code in order to create a compiler repro so the compiler can be fixed -- or:

2. the C# compiler is doing fine and xbuild is confused.

(2) is Bug #14767, which will be present in a future mono release.

You will need to determine if this is an actual C# compiler crash or not (by manually executing the `mcd` command line that diagnostic build output provides), and react accordingly.
Comment 2 renan jegouzo 2014-04-28 17:04:10 UTC
I can't reproduce it, now,
I fixed by building with visual studio.
it was just for you to know that it's bugged.
Comment 3 renan jegouzo 2015-12-15 08:19:09 UTC
seems OK now